Results 1 to 4 of 4
  1. #1

    02 Polaris virage 1200 txi unplug injector to get spark

    I am helping a friend work on a 2002 Polaris Virage 1200 TXI. When first looking at it I realized there was no spark and the fuel pump was not coming on. Looked at all recommendations, checked several things that tested ok (voltage, start/stop module, tps, fuses, etc.) and by just tinkering I unplugged the red/white wire going to the first fuel injector and all of a sudden had spark and fuel pump came on when trying to start. Fuel pressure is around 28 psi while cranking and will fire up for a short time with this one injector unplugged. The others do mot affect anything, only the first one (towards the front of the pwc). Runs rough obviously and started to back fire so I haven't done it again. If I plug the connector back in, no spark and no fuel. Any ideas? Thanks for any help


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    My guess is that the EMM circuit for that injector has shorted.

    Backfiring is also an indication that the EMM needs repair.

    See my signature links for the info on DFI Technologies, who repair these EMM.

  3. #3
    Thanks for the suggestion. I e-mailed dfi to get their opinion of whether it is a emm problem or injector problem and a estimated cost of repair. I will let you know how it goes from here. Thanks again

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by Dlkemp83 View Post
    Thanks for the suggestion. I e-mailed dfi to get their opinion of whether it is a emm problem or injector problem and a estimated cost of repair. I will let you know how it goes from here...
    DFI seems to respond better to telephone.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 polari virage 1200 txi
    By BigE in forum Polaris Open Discussion
    Replies: 7
    Last Post: 09-22-2014, 06:59 PM
  2. 2002 Polaris Virage 1200 TXi tough cold starts
    By coolgary76 in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 11-22-2013, 02:35 PM
  3. 2002 Polaris Virage 1200 TXI Backfires
    By gleathem in forum Polaris Open Discussion
    Replies: 12
    Last Post: 06-15-2011, 09:40 PM
  4. Need Polaris virage 1200 txi manual
    By kaulazs in forum Polaris Open Discussion
    Replies: 2
    Last Post: 05-10-2011, 02:01 PM
  5. 2002 polaris virage 1200 txi need more speed
    By john8873 in forum Polaris PWC Performance
    Replies: 2
    Last Post: 05-24-2007, 04:44 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •