Results 1 to 5 of 5
  1. #1

    powervalve problems help

    i have an 04 gp1300 rpms wouldnt go over 4000 5000 rpm instantly stop checked it out the pv motor was trying to cycle but seems like the shat will not move havnt got into it yet but if anyone has had a problem like this to possibly help out when i do thanks


  2. #2
    Yeah I did and it needs a new top end now cause it dropped the valve into the motor. I would suggest not riding it anymore until you get them serviced. They need to be cleaned periodically apparently. Also make sure you have those waveater clips on them. Mine wouldn't quite go to redline and was low on power. I didn't realize it was the powervalves. Oh well. From now on I'm going to service mine every 50hrs just to be safe.

  3. #3
    Quote Originally Posted by wavejunky22 View Post
    Yeah I did and it needs a new top end now cause it dropped the valve into the motor. I would suggest not riding it anymore until you get them serviced. They need to be cleaned periodically apparently. Also make sure you have those waveater clips on them. Mine wouldn't quite go to redline and was low on power. I didn't realize it was the powervalves. Oh well. From now on I'm going to service mine every 50hrs just to be safe.

    didnt no they needed to be seviced but i orderd the wave eaters last week ive been waiting for them to come just my luck im sure theyll show up tomorrow lol

  4. #4
    Neither did I. It's kind of a poorly engineered design. That's the thing with engines. Some are bullet proof and will run forever and some engines require a little more tlc over their lifespan.

  5. #5
    Does anyone have the procedure to service power valves? I have a 1999 1200 xl ltd. Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. R&D grate Defective or no problem??? Help...
    By Tiburon in forum 4-Tec Performance
    Replies: 3
    Last Post: 09-24-2006, 06:45 PM
  2. Cavitation Problem? Help!
    By NeverEndn in forum 4-Tec Performance
    Replies: 41
    Last Post: 08-10-2006, 10:01 PM
  3. Weird voltage drop problem help!
    By NateGP1300R in forum Yamaha PWC Performance (2-stroke)
    Replies: 33
    Last Post: 07-29-2006, 08:08 PM
  4. RXP problems... help
    By mgo7483 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-03-2006, 06:13 PM
  5. GP1200R Problems - HELP!!!
    By ramnj in forum Yamaha PWC Performance (2-stroke)
    Replies: 47
    Last Post: 06-05-2006, 08:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •