Results 1 to 6 of 6
  1. #1

    RXP-X 12 Fault code P0106, What to do?

    Hello guys!

    Ima a newbie to this forum, and i also bought my first scooter last week, a early august 2012 RXP-X, been running for 40 hours.
    The ski has a problem, it gives me a P0106 Pressure out of range at intake manifold.
    the ski is still under warranty, but were working alongside a workshop a workshop up north here in sweden.

    So, the fault code is thrown around 5700-6000RPM, the boost gauge shows goes up to about half. The ski feels dull, almost like missing 100HP.
    We've pressurized the IC, and we found no leaks, didn't use a pressuremeter but there was quite alot of pressure as we removed the cap.
    We've removed the throttle house from the intake to see if there were any leaks, which there weren't. We've switched the pressure-meter to my friends working one (whom also has a 2012 RXP-X).
    We've checked the the soft hose before the supercharger, it doesn't budge as you give it some gas on the water.

    But, some of the hoses has some grey goo inside, perhaps from the SC? And if you remove the soft air-hose and feel the wheel and axle of the SC, you can move it perhaps a millimeter side to side, quite more than my friends RXP-X whichs SC wheels a bit more sturdier.

    Anyone got an idea what the heck i am to do next? Or am i close to a SC failure after 40H of runtime?
    Any tips would be greatly appreciated.

    Best Regards Kim


  2. #2
    jbombino's Avatar
    Join Date
    Jun 2007
    Location
    Hialeah, FL
    Posts
    636
    +1
    17
    Quote Originally Posted by bergstromkim View Post
    Hello guys!

    Ima a newbie to this forum, and i also bought my first scooter last week, a early august 2012 RXP-X, been running for 40 hours.
    The ski has a problem, it gives me a P0106 Pressure out of range at intake manifold.
    the ski is still under warranty, but were working alongside a workshop a workshop up north here in sweden.

    So, the fault code is thrown around 5700-6000RPM, the boost gauge shows goes up to about half. The ski feels dull, almost like missing 100HP.
    We've pressurized the IC, and we found no leaks, didn't use a pressuremeter but there was quite alot of pressure as we removed the cap.
    We've removed the throttle house from the intake to see if there were any leaks, which there weren't. We've switched the pressure-meter to my friends working one (whom also has a 2012 RXP-X).
    We've checked the the soft hose before the supercharger, it doesn't budge as you give it some gas on the water.

    But, some of the hoses has some grey goo inside, perhaps from the SC? And if you remove the soft air-hose and feel the wheel and axle of the SC, you can move it perhaps a millimeter side to side, quite more than my friends RXP-X whichs SC wheels a bit more sturdier.

    Anyone got an idea what the heck i am to do next? Or am i close to a SC failure after 40H of runtime?
    Any tips would be greatly appreciated.

    Best Regards Kim
    You may have a defective air temp sensor or manifold pressure sensor.
    Also if you still have original IC make sure to replace it with a different one.

  3. #3
    We have tried another manifold pressure sensor, but it didnt make any difference.

  4. #4
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    Quote Originally Posted by jbombino View Post
    Also if you still have original IC make sure to replace it with a different one.
    Are you thinking the IC is leaking causing the sensor to go bad?

    Also the gray goo is not a good sign. May be the SC seal went bad.

  5. #5
    Kiwi spanner handler
    Join Date
    Dec 2007
    Location
    Christchurch NewZealand
    Posts
    579
    +1
    13
    I had the same deal and the hose going to the s/c was sucking in under hard load try a test ride with it off, the ski I had doing it was throwing the code and new sensor etc didn't fix it.the rubber hose goes soft where the oil breather plugs into it.

  6. #6
    So, we found the problem. The SC has failed. The bearings were shaped like cubes, the few bearings that were still inside the SC. We found broken parts of some gear inside the engine, so a complete failure.

    Not bad for a 40h 2012 rxp.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. P0106 code, what to do?
    By lolzer in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 06-06-2013, 04:36 AM
  2. What to do to my RXP
    By rxpiowa in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 01-25-2008, 03:16 PM
  3. NEW 2007 RXP 0 hrs. What to do 1st?
    By stepjl in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 09-05-2007, 08:12 AM
  4. I Have Stage 1 In Rxp Now. What To Do Next?
    By TDSTYG in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-31-2007, 11:27 AM
  5. deep scratches in rxps hull on bottom WHAT to do?
    By macattack in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-23-2005, 09:37 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •