Results 1 to 3 of 3
  1. #1

    Unhappy Yamaha waverunner III 96 650cc problem. PLEASE HELP

    Hi I own a 96 yamaha waverunner III 650cc everything was ok until I took it to the lake yesterday the jet ski loss power and acceleration I cant even pull my tubing anymore. I check the impeller and everything look good, I did a compression test 125psi in both cylinders. what else can be? Please help

  2. #2

    Join Date
    Jul 2005
    Central North Carolina
    There is a small fuel filter in side the carburator fuel pump side that gets stoped up causing a power loss. When you run the engine does both sparkplugs seem to get hot the same temp. I am sure you replace the sparkplugs first if not do that for sure.

  3. #3
    mudslanger's Avatar
    Join Date
    Jul 2010
    Huntsville Al
    Check your exhaust box and make sure its not busted. . a exhaust leak will kill the power.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 Yamaha Waverunner stalls on idle (please help)
    By RyanPuckhaber in forum Yamaha PWC Performance (4-stroke)
    Replies: 14
    Last Post: 06-17-2013, 01:11 PM
  2. 701cc Yamaha Electrical Problems, please help!
    By jethog585 in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 08-07-2011, 08:05 PM
  3. Yamaha GP1200r problem please help...
    By Quottro in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 06-09-2011, 04:36 AM
  4. Help need 1995 Yamaha WAVERUNNER III GP Parts
    By ZIPPY in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 03-25-2010, 11:47 AM
  5. 1991 Yamaha Waverunner III starting problem
    By kwerner69 in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 08-31-2009, 12:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts