Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    syk03t's Avatar
    Join Date
    Jun 2012
    Location
    AUSTRALIA-sydney
    Posts
    213
    +1
    2

    2012 fx sho problem

    Ok guys my ski was on 68mph with a ribbon delete exhaust and filter, The ski was hitting the limiter hard of the line, Then i installed a intake grate but while i was at it i put in a new standard prop as mine was a little damaged got rid off a little limiter bounce but it's still there but re gps'd my ski and it went 64mph lost 4mph any idea why any help would be great


  2. #2
    Did you fit a Worx or R and d?

  3. #3
    syk03t's Avatar
    Join Date
    Jun 2012
    Location
    AUSTRALIA-sydney
    Posts
    213
    +1
    2
    Worx but surley it couldnt cut 4mph does prop pitch make u gain or loose speed. Whats best suited for my ski with those mods
    Last edited by syk03t; 08-25-2013 at 06:01 AM.

  4. #4

    Join Date
    May 2009
    Location
    Nashville, Tn
    Posts
    788
    +1
    90
    Which prop did you install while you where in there?

  5. #5
    syk03t's Avatar
    Join Date
    Jun 2012
    Location
    AUSTRALIA-sydney
    Posts
    213
    +1
    2
    A oem factory new 1 do i need to repitch it with those mods
    Last edited by syk03t; 08-26-2013 at 02:53 AM.

  6. #6
    leejax01's Avatar
    Join Date
    Apr 2011
    Location
    Jacksonville
    Posts
    1,161
    +1
    98
    Simply replace the intake to stock and retest as that is easier than the prop. I assume all riding conditions were the same. If still at 64, then your prop. If back up to 68, then your intake.

  7. #7
    syk03t's Avatar
    Join Date
    Jun 2012
    Location
    AUSTRALIA-sydney
    Posts
    213
    +1
    2
    Could the intake grate make me loose that much speed ??? Hope not

  8. #8
    syk03t's Avatar
    Join Date
    Jun 2012
    Location
    AUSTRALIA-sydney
    Posts
    213
    +1
    2
    ???????????

  9. #9

    Join Date
    May 2009
    Location
    Nashville, Tn
    Posts
    788
    +1
    90
    I think dragdaddy lost similar speed with the R&D grate. Personally I would be surprised if either are knocking off 4mph. I would do a run, bolt back the stock grate at the ramp and run again. Think that's the only way your going to find out your answer.

  10. #10
    Dragdaddy71 Dragdaddy71's Avatar
    Join Date
    May 2007
    Location
    Moline , IL
    Posts
    126
    +1
    1
    I did lose 4mph but I called R&D and they are going to look at the grate for me. I have yet to mail it back yet. My ski is a SHO Cruiser.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2012 FX SHO RPM/Speed Problem
    By 808 in forum Yamaha PWC Performance (4-stroke)
    Replies: 14
    Last Post: 02-03-2014, 05:16 PM
  2. 2012 FX SHO Cruiser
    By nashvegas in forum Yamaha PWC Performance (4-stroke)
    Replies: 73
    Last Post: 01-05-2013, 12:06 AM
  3. New 2012 FX SHO in the House!
    By john belton in forum Yamaha PWC Performance (4-stroke)
    Replies: 56
    Last Post: 03-26-2012, 08:28 PM
  4. 2012 FX SHO vs FZR
    By jp1300r in forum Yamaha PWC Performance (4-stroke)
    Replies: 17
    Last Post: 03-07-2012, 09:27 AM
  5. 2008 Fx Sho Problems?
    By DOERUN in forum Yamaha PWC Performance (4-stroke)
    Replies: 19
    Last Post: 08-10-2008, 11:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •