Results 1 to 9 of 9
  1. #1

    97 seadoo xp overheated

    I have owned this ski for a few years now and it has never given me any serious issues until my last ride out.

    The ski was running great for about an hour. I was a few miles from the ramp and had sucked something into the pump and had a serious vibration. I immediately shut it down and swam it to shore and began my inspection. I noticed a white piece of plastic stuck in the pump so I pushed it out with a stick I found on land. Everything looked good so I jumped on the ski and rode off.

    After a short ride the overheat buzzer came on and I shut it down again. I swam it to shore for the second time and popped the engine cover and the hull was filled with smoke. I began my search for the problem and realized my water filter for the inlet water was packed with mud. I did not want to chance any damage so I towed it back to the ramp.

    I took it home and blew all the lines out, everything was clear. I ran it on the hose for a few minutes and everything seemed fine and the engine stayed cool.

    Is there anything I should check before taking it back to the river or should I be OK ?

    Thanks , Chris


  2. #2
    The smoke in the engine bay concerns me?? But you said you ran it on the hose and seemed fine.
    Keep an eye on the pisser when you take it back out.

  3. #3
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,529
    +1
    1,279
    you may have melted an exhaust hose.

    back the trailer in the water and run it for a couple of minutes to check for leaks. Pay attention to the hose that goes from the muffler box to the hull outlet. When water is restricted this hose can melt. Oh yeah. the rear hose is no longer available as new...

  4. #4
    Thank guys I should be taking it back out this weekend .... I will keep an eye out for everything you mentioned. I also tested compression and the cylinders are at 155 and 160.

  5. #5
    I just returned from my trip to the river. I ran the ski on the trailer in the water and had no leaks but I noticed no water coming out of the pisser at idle while stationary. I took the ski for a short ride to see if it needed more water flow and once I started moving water came out. Is this normal?

    Also how hot should the engine be getting? I might have been out for 5 min and the head and exhaust were getting fairly hot to the touch.

  6. #6
    OLD # 7 IEGPR's Avatar
    Join Date
    Dec 2006
    Location
    Rialto CA
    Posts
    964
    +1
    6
    Sounds like it was just the mud ! No leaks means you got lucky. And yes the head and exhaust will get that hot normally

  7. #7
    double check everything......there should be a little out of the pisser at idle???

    Do you have the hose flush hookup on the back by the jet pump....if you do, it kinda back-flushes the system when you run on the hose. Also the pisser will be a superpisser on the hose!

  8. #8
    It has water coming out at idle while the ski is off the trailer moving but when its stationary tied to the trailer and backed into the water no water comes out of the pisser

  9. #9
    holleynut's Avatar
    Join Date
    Jun 2009
    Location
    Galveston
    Posts
    42
    Yep, my 96 GSX does the same thing. Water hose will piss water out a lot further. My pisser trickles out idling in the water but my stream is about 4 feet back when I'm full throttle. On the water hose, it goes back about 10 feet. Right after a full throttle ride for 5 minutes, I can stop, pull the seat, grab upper pipe, head, and sides of cylinders. My only issue is the second section of pipe is really hot but that is on another post I just put up before finding this one.



    Quote Originally Posted by RIDEH2O View Post
    double check everything......there should be a little out of the pisser at idle???

    Do you have the hose flush hookup on the back by the jet pump....if you do, it kinda back-flushes the system when you run on the hose. Also the pisser will be a superpisser on the hose!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Who to see about 97 seadoo xp rebuild?
    By slinky in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 04-15-2009, 07:11 AM
  2. 97 seadoo xp bad engine looks great
    By jabbas in forum Sea Doo Classifieds
    Replies: 114
    Last Post: 07-18-2008, 11:38 AM
  3. 97 Seadoo XP Fuel/Oil coming out of exhaust
    By medinaao in forum 2-Stroke Performance
    Replies: 3
    Last Post: 05-28-2008, 06:25 AM
  4. 97 seadoo xp cutout
    By chris7230 in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 09-07-2007, 07:48 AM
  5. 97 seadoo xp flooding, help
    By czx234 in forum 2-Stroke Performance
    Replies: 5
    Last Post: 09-05-2007, 06:38 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •