Results 1 to 2 of 2
  1. #1

    ultra 150: running on 2 cylinders at 4500 rpms

    I was riding my Ultra and it cut off. It would not crank back up right away, but after 30 seconds it did. When I got back to the house I noticed the battery was not strapped down, and it shorted out and was touching the 3rd cylinder. My clock was reset. Now it will only run on 2 cylinders. I changed spark plugs and still only 4500 rpms. Is the coil pack blown? Does anyone know what might be wrong or what to check for?


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    5,014
    +1
    284
    Check for spark on all three before replacing any parts.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Running on one cylinder at idle
    By SixpCk823 in forum Polaris PWC Performance
    Replies: 5
    Last Post: 06-12-2015, 10:44 PM
  2. Ultra 150 running poor unless fuel on "reserve"
    By thetolleyman in forum Kawasaki PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-30-2012, 07:49 AM
  3. Ultra 150 running away on trailer??????
    By nz253 in forum Kawasaki Open Discussion
    Replies: 9
    Last Post: 08-19-2011, 07:44 PM
  4. SL 750 Running on Two Cylinders at Idle
    By safd18fire in forum Polaris Open Discussion
    Replies: 1
    Last Post: 08-15-2010, 05:43 PM
  5. 96 sl-780 Missing on pto cylinder at high rpm
    By gvnitup in forum Polaris Open Discussion
    Replies: 8
    Last Post: 08-25-2009, 10:26 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •