Results 1 to 4 of 4

Thread: Dam jet mate!

  1. #1
    TROY1974's Avatar
    Join Date
    Jun 2012
    Location
    ONTARIO, LAKE SIMCOE
    Posts
    12
    +1
    2

    Dam jet mate!

    I have a 1990 jet mate with a 750 cc engine
    when testing it in the lake it will idle around slow but when you try to go fast it just revs up and
    wont go fast just revs up has a new impeller feels like air in the jet drive
    any ideas why wont take off and go?


  2. #2
    Formerly Ultra250 TN Aquaholic6801's Avatar
    Join Date
    Feb 2007
    Location
    Old Hickory,Tn
    Posts
    5,446
    +1
    650
    You answered your own question.....theres cavitation for some reason....wrong prop...things not sealed properly, stator damages........

  3. #3
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    What prop do you have? Stock 650?

  4. #4
    TROY1974's Avatar
    Join Date
    Jun 2012
    Location
    ONTARIO, LAKE SIMCOE
    Posts
    12
    +1
    2
    Have maco impeller

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kawasaki Jet Mate 900 Zxi swap
    By Codert in forum Kawasaki Projects
    Replies: 50
    Last Post: 08-13-2014, 08:31 PM
  2. Jet mate won't start?
    By Ncp546 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 41
    Last Post: 11-24-2013, 12:36 PM
  3. kawasaki jet mate
    By engel moving in forum Kawasaki Classifieds
    Replies: 2
    Last Post: 08-29-2013, 09:06 AM
  4. stupid jet mate
    By TROY1974 in forum Kawasaki How To & FAQs
    Replies: 3
    Last Post: 07-09-2012, 02:18 PM
  5. Jet Mate motor upgrade
    By macio in forum Kawasaki How To & FAQs
    Replies: 4
    Last Post: 02-05-2012, 11:06 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •