Results 1 to 9 of 9
  1. #1

    Msx150 battery won't charge

    I have a 2004 msx 150 that's not charging the battery. The 30 amp fuse was blown, so I replaced it and installed a new battery. When I check the voltage at the battery and start the engine, the voltage drops to 11.9. Revving the engine doesn't change it. Does this sound like the voltage regulator? If so, how the hell do you get to it? Any insight would be greatly appreciated.


  2. #2
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    Welcome to GH!

    If you are only seeing 11.9 volts at the battery while the ski is running... then yeah, sounds like you have a bad voltage regulator. I've heard of them going out... but it's not very common. Sorry if this is your case.

    They are not easy to get to. They are under the intercooler (front of engine) on a bracket attached to the oil cooler mounting bracket. Unbolt the IC and lift it back and sit/prop it up on the gas tank and strap it in place. I run a cinch strap under the IC and put one end on the steer column bracket above the gas tank and the other end on the seat catch loop and cinch the IC to stay on top of the gas tank. Now you will need to reach under there and unbolt the upper oil cooler brackets (green arrow in pic)... one on each side... then the bracket holding the VR will come out... and you need to unplug the 2 connectors.

    Click image for larger version. 

Name:	MSX_VR_pic.JPG 
Views:	80 
Size:	74.3 KB 
ID:	312017

    Cheers!

  3. #3
    Kosh's Avatar
    Join Date
    Sep 2007
    Location
    Australia
    Posts
    1,483
    +1
    83
    Or just plug a new one in and find a place to strap it up until you need to get in there another time

  4. #4
    Thanks, I like that idea.

  5. #5
    Where does the regulator plug in at?

  6. #6
    Kosh's Avatar
    Join Date
    Sep 2007
    Location
    Australia
    Posts
    1,483
    +1
    83
    Quote Originally Posted by Dougied View Post
    Where does the regulator plug in at?
    Two plugs, still a bugger to get to, right hand side front 3wire and 2wire.
    You'll get one cheaper than this but it has good pictures.
    http://www.ebay.com/itm/Polaris-Jets...21c159&vxp=mtr

  7. #7
    I just bought an MSX150. 52 hours on it. It was in the shop before I bought due to it not reving up. Shop said it was clogged fuel line. So, I bought it after I thought all was well. Take it out and a short time later the battery light starts flashing. Sure enough, battery wasn't charging. I checked the stator fuse. Not blown. Just had new battery installed in it. Charged the battery and fired it up to test voltage. 12.51 volts before starting it and it drops to about 12.3 while running. Is this still the voltage regulator even though the fuse wasn't blown? Could it be anything else?

  8. #8
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    Welcome to Green Hulk happymeal!

    Hmm... yeah, that doesn't sound like your engine is charging properly. You should see around 13.5v while running at the battery. You too might be experiencing a voltage regulator issue. Assuming known good battery... that would be my next thing to look at.

    Cheers!

  9. #9

    MSX 150 Won´t Charge

    Hi Guys,

    I have a problem and can not get any further.
    I have installed a new voltage regulator. There are also 14.4 volts on the yellow / red cable. On the battery, however, only 12.5 volts during running. Battery is new. Fuse is whole. Cable I have all checked. Even if I go directly from the voltage regulator to the battery I see only 12.5 volts.

    Should not 13.1 Volt be pending?

    Best regards from Germany

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new battery won't stay charged
    By cyphyr in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 06-26-2012, 04:10 PM
  2. Polaris MSX 150 question...battery won't stay charged.
    By rjcapo02 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-29-2010, 11:21 PM
  3. Battery won't charge
    By FLSUN in forum Sea Doo Open Discussion
    Replies: 11
    Last Post: 11-28-2009, 02:02 PM
  4. Battery won't charge
    By rivermann50 in forum 2-Stroke Performance
    Replies: 17
    Last Post: 04-19-2009, 10:42 AM
  5. won't charge battery
    By 96xp800 in forum 2-Stroke Performance
    Replies: 13
    Last Post: 08-04-2008, 07:58 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •