Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1

    Does this look like excessive carbon from seal?

    I have a 2013 GTI 130 SE with 11 hours on it so far. Looking under the seat when checking the oil there appears to be a good bit of carbon dust. Is this amount normal for the hours or do you guys think I have a problem?

    Thanks in advance.


  2. #2
    Mothman's Avatar
    Join Date
    May 2011
    Location
    West Texas
    Posts
    2,997
    +1
    1,478
    That's excessive. How long did you run it on the hose?

  3. #3
    Maybe 45 seconds to a minute. I've only ran it in fresh water so I didn't think it really needed more than that.

  4. #4
    Mothman's Avatar
    Join Date
    May 2011
    Location
    West Texas
    Posts
    2,997
    +1
    1,478
    The engine may have been misaligned from the factory. I've never seen that much dust from any brp watercraft. Does it cavitate when you hammer the throttle from a dead stop? Is there any water in your hull after riding? Pop the seat and peek inside while riding (if you feel comfortable doing this) and look to see it water is squirting out from around the carbon seal. If it is, time to realign the engine and install a new carbon seal.
    Good luck!

  5. #5
    No cavitation that I can tell. It accelerates fast, and I don't feel any vibration. There is a slight amount of water in the hull after riding, maybe a couple of ounces at the most. Thanks for the advice.

  6. #6
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    I had same issue earlier. Think it was how I had hose clamp on carbon ring( not in grove). It was uneven and wore in wrong. Had shit everywhere...

  7. #7
    ProZadoX's Avatar
    Join Date
    Jan 2008
    Location
    Ottawa, Canada
    Posts
    351
    +1
    55
    Not normal... to the dealer!

  8. #8
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    Most definitely abnormal! You probably have a lot of cavitation on hole shot. I have near a 100 hours on my TX and have ZERO carbon ring dust.

    The engine may be aligned correctly with the pump BUT, the thru hull fitting holding the bellows and carbon ring could be way out of whack! troyheb had the same problem on his PX.
    The entire drive line needs to have all these components checked for proper alignment. Do NOT clean it up and take it to the dealer.

    Start reading this thread post # 332 and on - I bet this is your problem: http://www.greenhulk.net/forums/show...170389&page=34


  9. #9

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    3,446
    +1
    653
    my 2012PX was way mis-aligned from the factory. Had to add 2 shims to the rear and take one shim from the front. I had a fair amount of dust, when I measured the thickness against new ring it was a little less than a millimeter difference. Can you take a close up of the carbon ring/metal hat area? Lift the PTO flap. By the way my engine/drive train sounds way smoother with a fresh alignment.

  10. #10
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 25
    Last Post: 04-06-2014, 08:56 PM
  2. what does this look like to you guys oil?
    By stingray152003 in forum Yamaha Open Discussion
    Replies: 9
    Last Post: 07-13-2008, 02:44 AM
  3. Does this look like a scam? 06 RXP 4K
    By Fast-XPL in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 06-05-2008, 04:01 PM
  4. Does this look like it should?
    By porksword in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 01-07-2007, 09:47 PM
  5. helmet cam...does this look like a good one
    By WATER WOODY in forum Yamaha Open Discussion
    Replies: 12
    Last Post: 12-30-2006, 01:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •