Results 1 to 2 of 2
  1. #1

    Xlt 800 help plz

    Hi new to the forum and would like a little help if possible please.
    just rebuilt my 2003 xlt 800 engine and all went well.
    went to start for the first time and nothing.
    changed the fuse, checked wires etc.
    reprogrammed my security code to start, still nothing.
    not even any power valve movement or beeps when lanyard connected.
    but the mode button does work on the display.
    totally lost now.


  2. #2
    100 MILES OF HEAVEN AND I AM SMACK IN THE MIDDLE KEYZBUM's Avatar
    Join Date
    Apr 2007
    Location
    JUST NORTH OF CUBA-- FL,KEYS
    Posts
    2,556
    +1
    39
    Welcome to the Hulk.
    Sound like you need to get a multi-meter and start looking for bad grounds,etc

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Newbie looking for help. '02 XLT 800 engine issue
    By BlueHurricane in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-19-2012, 02:22 AM
  2. polaris msx 150 burning oil limeted rpm help plz
    By ln69bt in forum MSX/Matrix
    Replies: 22
    Last Post: 04-09-2008, 10:54 AM
  3. Oil Seal part number xp 800, Help
    By dre23 in forum 2-Stroke Performance
    Replies: 6
    Last Post: 12-26-2006, 07:26 PM
  4. need xlt 800 compression/psi
    By dhoad in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 12-15-2006, 01:33 PM
  5. anybody modded xlt 800
    By dhoad in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 07-04-2006, 09:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •