Results 1 to 5 of 5
  1. #1
    surferd15's Avatar
    Join Date
    Jun 2007
    Location
    Fort Lauderdale, FL
    Posts
    1,142
    +1
    83

    Lost all my oil??

    Had my alignment done two rides ago. Last ride I notice what looked like muddy water in my hull. I did alot of riding and prob got water in there so I didn't think too much of it. Cleaned and stored the ski. I notice there was still some stuff in the bottom of the hull, but thought it was left from last time. Rode again today and the "muddy water" was back. This time I inspected it and its def. oil and I checked my dipstick and only a lil oil registers on the stick....great. Last work I had done was an alignment. I was thinking its leaking from the PTO? What would cause this? It def started leaking after it was aligned and the alignment was way out of whack. I also found some unidentified objects in my hull--a bolt and a round metal type spacer or plug?? I'll try and get a pick.


  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    Click image for larger version. 

Name:	bellows.jpg 
Views:	50 
Size:	43.6 KB 
ID:	312196
    the bellows with the bearing is sold as 1 part and 2 O-rings on the drive shaft
    ripped boot/bellows or bad bearing or just you pulled the bearing out of the bellows..... most likely

  3. #3
    surferd15's Avatar
    Join Date
    Jun 2007
    Location
    Fort Lauderdale, FL
    Posts
    1,142
    +1
    83
    Update: Dealer fixed the issues said the bellow is tapered and it gives some room to leak on the shaft so they replaced the factory clamp with a heavier duty clamp. Filled with oil, tested and all is well.

  4. #4
    Quote Originally Posted by surferd15 View Post
    Update: Dealer fixed the issues said the bellow is tapered and it gives some room to leak on the shaft so they replaced the factory clamp with a heavier duty clamp. Filled with oil, tested and all is well.
    that's good news

  5. #5
    Eastside Powersports Slow 91's Avatar
    Join Date
    Sep 2008
    Location
    River Crew CT
    Posts
    4,248
    +1
    544
    once that bearing comes out of the bellow, I usually replace the whole thing. There is also an oil seal in the crank that is known to cause leaks.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loseing all my oil through exhaust help please
    By river123 in forum Honda Open Discussion
    Replies: 6
    Last Post: 07-17-2014, 10:51 PM
  2. Brand newbie...lost all my fuel
    By Nokitov in forum Polaris Open Discussion
    Replies: 8
    Last Post: 07-06-2012, 10:19 AM
  3. Lost all my engine bids =( how about this one?
    By rdizz81 in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-29-2010, 10:10 PM
  4. Pics of my oil catch tank
    By Chezzy in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-18-2006, 08:35 PM
  5. popped my oil change cherry
    By Lurker in forum 4-Tec Performance
    Replies: 9
    Last Post: 08-26-2005, 09:23 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •