Results 1 to 6 of 6

Thread: Seaweed trouble

  1. #1

    Seaweed trouble

    1997 GTX
    Ran through some seaweed/moss stuff. Stopped and cleansed it out, but its not running good. Any ideas?


  2. #2
    Can seaweed or mass cause a problem?

  3. #3
    Banned User
    Join Date
    Aug 2011
    Posts
    5,049
    +1
    238
    Yea find a new lake son!

  4. #4
    Mothman's Avatar
    Join Date
    May 2011
    Location
    West Texas
    Posts
    2,999
    +1
    1,479
    Check your water lines. They may be clogged.

  5. #5
    Sturm215's Avatar
    Join Date
    May 2010
    Location
    Lakeland florida
    Posts
    1,893
    +1
    64
    make sure you got it all out of the grate and impeller area.

  6. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    If you clog the cooling lines you can fry the motor fast.
    Make sure you have a full stream of water coming out of the cooling pissers.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Tip: Trouble codes for 4 Tec's
    By Green Hulk in forum Sea Doo How To & FAQs
    Replies: 73
    Last Post: 06-02-2017, 07:34 PM
  2. 12 Offshore Oil Rigs in trouble...USCG
    By Denali44 in forum Sea Doo Open Discussion
    Replies: 16
    Last Post: 09-01-2005, 11:23 PM
  3. trouble code ?
    By Krazy-K in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-01-2005, 07:18 PM
  4. Replies: 22
    Last Post: 07-13-2005, 09:33 PM
  5. Impeller Shaft Trouble
    By WildBill9000 in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 06-06-2005, 10:46 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •