Page 1 of 2 1 2 LastLast
Results 1 to 10 of 14
  1. #1
    Laxcrazy23's Avatar
    Join Date
    Sep 2007
    Location
    Manahwakin
    Posts
    611
    +1
    7

    supercharger or something else

    I was experiencing cavatation on my 08 rxpx so i replaced the wear ring, but still having some issues out of the hole. Now i am hearing a "whirring" at idle and it increases if i give it any gas, also the ski does feel like it is cavatating when accelerating. Ski has 134 hours on it but the supercharger was rebuilt at 80 hours. Is it a bearing that i am hearing or is it something else? Dont really hear the whirring out of the water thoughts? Im thinking its the supercharger on its way out.

    Thanks in advance.


  2. #2
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246
    Ck your carbon ring for the cavitation. Whirring could possibly be a pump bearing. Pull the pump and ck.

  3. #3
    Laxcrazy23's Avatar
    Join Date
    Sep 2007
    Location
    Manahwakin
    Posts
    611
    +1
    7
    Quote Originally Posted by dpracing View Post
    Ck your carbon ring for the cavitation. Whirring could possibly be a pump bearing. Pull the pump and ck.
    What should i check for in the pump? I just had it out replacing the wear ring and it spun smoothly, no grinding.

  4. #4
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    When you rebuilt the charger at 80 hrs did you put new bearings and washers??
    If not then pull it and do both.. better safe then really sorry...

  5. #5
    Laxcrazy23's Avatar
    Join Date
    Sep 2007
    Location
    Manahwakin
    Posts
    611
    +1
    7
    Quote Originally Posted by wotxxxsd View Post
    When you rebuilt the charger at 80 hrs did you put new bearings and washers??
    If not then pull it and do both.. better safe then really sorry...
    was a full rebuild

  6. #6
    Laxcrazy23's Avatar
    Join Date
    Sep 2007
    Location
    Manahwakin
    Posts
    611
    +1
    7
    been a while...but had the carbon seal looked at on land and it is in decent shape. Whirring noise exists still, but can only hear it when ski is in the water. Still has issues out of the hole but runs fine other then that. Im pretty convinced that the pump bearing is on its way out, is there anyway to check? Impeller spins fine when i have the pump out.

    Also assuming if it was something internal in the motor i would hear it on land or it would have let go by now.

  7. #7
    Mothman's Avatar
    Join Date
    May 2011
    Location
    West Texas
    Posts
    2,996
    +1
    1,477
    Pull the rubber boot backwards. If you can pull the carbon from the hat easily, the boot is weak. Easy cheesy to replace and it'll (most likely) solve the cavitation issue. The 'whirring' noise may be the supercharger whine if you've changed the intake system. Pop the intake loose and try to spin the charger wheel with your fingers.
    Good luck!

  8. #8
    Laxcrazy23's Avatar
    Join Date
    Sep 2007
    Location
    Manahwakin
    Posts
    611
    +1
    7
    Supercharger is rebuilt as of 2 hours ago on the motor and intake is the same. Any idea how to tell if the bearing in the pump is on its way out?

  9. #9
    Laxcrazy23's Avatar
    Join Date
    Sep 2007
    Location
    Manahwakin
    Posts
    611
    +1
    7
    So I finally got to the bottom of this problem, pump bearing is toast. What do you guys know about rebuilding the pump or the "replacement" pump?. They are all black runs about $400 for everything but prop.

  10. #10
    baba850r's Avatar
    Join Date
    Sep 2007
    Location
    scotland
    Posts
    673
    +1
    4
    What was you running in your pump cone oil or grease?
    when was last time you pulled pump come ?

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Wear Ring Or something else wrong
    By 992door in forum 2-Stroke Performance
    Replies: 6
    Last Post: 03-21-2012, 08:56 PM
  2. Is This What a PV failure looks like or something else?
    By mgppilot in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-20-2011, 08:41 PM
  3. Problem with rxt-x 260 or something else
    By rxp1972 in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-20-2010, 11:16 PM
  4. Yamaha GP1300R vs STX15F (or something else)
    By Robbbin in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 07-06-2009, 07:23 PM
  5. 07 RXP issue, prop or sc clutch or something else?
    By blandis in forum 4-Tec Performance
    Replies: 9
    Last Post: 09-08-2007, 06:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •