Results 1 to 3 of 3
  1. #1

    2005 New to me Speedster 200 370hp

    Hey all,
    I just picked up a 2005 Speedster 200 w/the twin 185 s/c engines and I'm really excited to get this on the water. I did water test it and it ran really good, but there are a couple issues...Both Tachometers are not working at at...not even any movement when I start it. I did try to give them a tap but nothing. Any suggestions?

    Thanks in Advance!
    Last edited by kane; 09-02-2013 at 09:14 PM.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,591
    +1
    1,275

  3. #3
    Haha!! Yeah I wrote that this morning, but thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New to me Speedster I am modding, Questions/ recommendations!!
    By rundo's 900zxi in forum Sea Doo Sport Boats
    Replies: 5
    Last Post: 08-09-2016, 02:25 PM
  2. new to me 2005 rxt, few questions
    By blacktop in forum 4-Tec Performance
    Replies: 21
    Last Post: 05-28-2013, 07:35 PM
  3. New to me 2005 RXP (red supercharger ?)
    By edge in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-28-2012, 11:20 AM
  4. Replies: 1
    Last Post: 03-01-2011, 04:24 PM
  5. need help 96 speedster new to me
    By lp*rp in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 06-26-2007, 07:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •