Results 1 to 3 of 3
  1. #1

    2005 New to me Speedster 200 370hp

    Hey all,
    I just picked up a 2005 Speedster 200 w/the twin 185 s/c engines and I'm really excited to get this on the water. I did water test it and it ran really good, but there are a couple issues...Both Tachometers are not working at at...not even any movement when I start it. I did try to give them a tap but nothing. Any suggestions?

    Thanks in Advance!
    Last edited by kane; 09-02-2013 at 09:14 PM.

  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada

  3. #3
    Haha!! Yeah I wrote that this morning, but thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. new guy with speedster question.jet pump
    By qkv8 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 02-20-2012, 11:29 PM
  2. Help trouble with new 2007 150 speedster 155hp
    By fugazi in forum Sea Doo Sport Boats
    Replies: 4
    Last Post: 09-18-2007, 07:59 AM
  3. New 2007 150 speedster owner newbie questions
    By fugazi in forum Sea Doo Sport Boats
    Replies: 1
    Last Post: 09-15-2007, 09:27 PM
  4. New Guy - '07 Speedster 150 155hp
    By burninoneup in forum Sea Doo Sport Boats
    Replies: 2
    Last Post: 06-28-2007, 07:16 PM
  5. New 07 200 Speedster
    By bigmaui in forum Sea Doo Sport Boats
    Replies: 7
    Last Post: 06-19-2007, 06:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts