Results 1 to 3 of 3

Thread: 2011 Ultr LX

  1. #1

    2011 Ultr LX

    This last week end it started to run bad, like something was in the water pick up. Put on trailer and checked, nothing there. At low RPMS it runs fine, but if you give it WOT it revs up but does not go hardly at all. About 35 is all it will do. Ski is all stock and only had 47 hours on it. Any ideas what could be causing this.

  2. #2
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Check the thread in my signature then post back. Follow the order and odds are it will be easy to fix.


  3. #3
    The whole pump was toast. Something went through it and pretty much trashed it. the threads on the impeller were half gone and it had been rubbing the housing. Have to replace everything.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Barrett-Jackson 2010,2011
    By beerdart in forum Open Discussion
    Replies: 13
    Last Post: 01-17-2012, 08:04 PM
  2. Seadoo 2011 Engine info (may not be correct)
    By Pooper_Scooper in forum 4-Tec Performance
    Replies: 25
    Last Post: 06-04-2010, 10:57 AM
  3. The WetDog 2000 Mile PWC Endurance Race May, 2011
    By OsideBill in forum Race Events and News
    Replies: 27
    Last Post: 10-03-2009, 09:09 PM
  4. 2011 Trans Am
    By RX951 in forum Open Discussion
    Replies: 27
    Last Post: 09-08-2008, 12:46 PM
  5. WTB: Ultr 150 rub rail-black
    By Duane Hawley in forum Kawasaki Classifieds
    Replies: 0
    Last Post: 07-11-2008, 10:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts