Results 1 to 6 of 6
  1. #1

    2000 LRV help!!!!

    I am new to this forum and hope to get some advice for a problem I am having. I have a 2000 LRV with a carbed 951 motor . The ski shuts off as if the DESS key has been pulled only if you gun it out of the hole or apply full throttle while under way. You can cruise around 30, 40, 45 MPH with no issues. Also will periodically shut off if you hit a wake pretty hard. The ski will immediately start back up when I hit the start/stop button. I did notice that that the clock will reset back to 12:00 and all other stored info, peak speed, avg speed and distance are all reset also. Any advice or info will be great thanks.


  2. #2
    If i knew,...I wouldn't ask sea-one's Avatar
    Join Date
    Aug 2009
    Location
    Dallas/Waxahachie
    Posts
    2,340
    +1
    109
    Well i'd say its electrical, Check the main cables, The ground wire cable to the block and the positive cables in the solenoid box. If thats not it,start checking all your harness plugs

  3. #3
    Quote Originally Posted by sea-one View Post
    Well i'd say its electrical, Check the main cables, The ground wire cable to the block and the positive cables in the solenoid box. If thats not it,start checking all your harness plugs
    I have cleaned and checked main ground, ground on mag cover and ground on rear electrical box. Harness seems good do not see any issues. Are there any components that may cause this issue? I have replaced the DESS key, I did this before I noticed the info settings resetting.

  4. #4
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Double check all your dess connections since you just were wrenching on it..

  5. #5
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Welcome aboard the Hulk!!

    That's a mother load of a ski you have..
    I've seen those skis 25-35 miles off shore and fully rigged for fishing..
    Got to love a turd that size...

  6. #6
    Was out in the garage trying to find anything and I noticed as your starting the ski will stop turning over just for a very brief moment and the clock is reset back to 12:00. I have the sea doo service manual and its about worthless as far as this issue goes. Could it be a possible MPEM going bad? Just doesn't make any sense!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 RX Help
    By 00rx in forum 2-Stroke Performance
    Replies: 5
    Last Post: 05-23-2010, 08:18 AM
  2. 2000 ultra help
    By turbogn in forum Kawasaki PWC Performance (2-stroke)
    Replies: 10
    Last Post: 03-29-2010, 07:06 PM
  3. 2000 gtx help
    By xpfreak in forum 2-Stroke Performance
    Replies: 5
    Last Post: 06-16-2009, 05:35 PM
  4. 2000 XP help
    By GRM in forum 2-Stroke Performance
    Replies: 16
    Last Post: 06-04-2009, 10:35 AM
  5. 2000 LRV
    By LRVBOAT in forum 2-Stroke Performance
    Replies: 3
    Last Post: 04-20-2009, 11:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •