Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 33

Thread: Polaris sl1050

  1. #1

    Polaris sl1050

    Hi I'm new to green hulk and in need off some help with my polaris sl1050 97model. I bought this ski with the crank / pistons gone I've had all the engine done and is back in the ski but I can only get a very week spark. I've checked earths and spark plug leads for damage but now I'm stuck ????? Please help


  2. #2
    Moderator boataddict's Avatar
    Join Date
    Apr 2005
    Location
    Ottawa, Ontario, Canada
    Posts
    3,822
    +1
    39
    Did you put a new battery in? The battery can be strong enough to roll it over but not strong enough to get spark.

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Welcome

    See my signature links for some diagnostic info on the red domestic engine.

    In particular, ohm test the magneto stator and the Hall Effect sensors.

    As already mentioned, these engines really want a strong battery. A not quite good enough battery can make you chase your tail with diagnostics.

  4. #4
    I will start with battery take it off and give it a good charge. K447 this info is very helpfull but I'm not very good with a multi meter but I will try my best as I need to fix this ski. Thank you

  5. #5
    I've tried it with another battery and the spark is the same??? Is there anyway I could check the coil?

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by Matt h View Post
    ... Is there anyway I could check the coil?
    Quote Originally Posted by K447 View Post
    ... See my signature links for some diagnostic info on the red domestic engine.

    In particular, ohm test the magneto stator and the Hall Effect sensors. ...
    Time to get more familiar with your multi-meter.

    An easy test is to hold down the Bilge button and also press Start. Does it have stronger spark?
    Last edited by K447; 09-30-2013 at 09:01 AM.

  7. #7
    I will try the bilge button see if I get a better spark then ill try the tests with the meter thanks again

  8. #8
    From reading threw the forum I'm thinking I'm going to need the update kit for my polaris does anyone no were I could get one from and how much ?? Cheers matt polaris sl1050 97 model

  9. #9
    The spark is the same with the bilge button pressed. I've noticed a red light flashing on the display pannel and numbers counting up and down. then when I crank the screen goes off for a second then it's back on ??? Is the red light some type of warning light?

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,570
    +1
    1,272
    Quote Originally Posted by Matt h View Post
    The spark is the same with the bilge button pressed. I've noticed a red light flashing on the display pannel and numbers counting up and down. then when I crank the screen goes off for a second then it's back on ??? Is the red light some type of warning light?
    Something is not right. Either the MFD has an internal problem, or there is a problem in the electrical system.

    Measure the battery voltage while cranking. It should stay above 10.6 volts the entire time the engine is cranking. If not, battery is weak.
    Last edited by K447; 09-19-2013 at 12:12 PM.

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FS Now Parting Out a Complete 1997 Polaris SL1050
    By jetskidude in forum Polaris Classifieds
    Replies: 3
    Last Post: 12-21-2011, 04:17 PM
  2. FS polaris sl1050
    By ryandi2 in forum Polaris Skis
    Replies: 12
    Last Post: 10-05-2010, 08:52 AM
  3. **1997 polaris SL1050**
    By jonny23 in forum Polaris Skis
    Replies: 11
    Last Post: 06-30-2009, 05:46 AM
  4. 97 polaris sl1050 pump assembly
    By fuji600 in forum Polaris Classifieds
    Replies: 0
    Last Post: 06-18-2009, 01:40 PM
  5. 97 Polaris sl1050
    By [email protected] in forum Polaris Open Discussion
    Replies: 2
    Last Post: 09-09-2008, 10:16 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •