Page 1 of 2 1 2 LastLast
Results 1 to 10 of 18
  1. #1
    srjrinc's Avatar
    Join Date
    Aug 2012
    Location
    Sun Valley, CA
    Posts
    122

    No water in water box!

    So I'm finally taking apart my 05' RXP project (NO Compression in #1- 130 in #2 & 3 " Finally Bought a Broken RXP" thread) and I found literally NO water in the water box........
    Would this have anything to do with my current compression issue??? I'm also having trouble pulling out the pump... It should slide right out according to the other threads that I have read.
    The shaft is rusted really bad, is there a clip or something I'm missing???

    Thanks in advance for your help guys!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	DSC01249.jpg 
Views:	67 
Size:	81.5 KB 
ID:	312863   Click image for larger version. 

Name:	DSC01247.jpg 
Views:	67 
Size:	86.8 KB 
ID:	312864  


  2. #2
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,334
    +1
    261
    Its under the SS hat. Its doesn't look like its going to move though. May have to start cutting the shaft. Looks unuseable anyway.

  3. #3
    srjrinc's Avatar
    Join Date
    Aug 2012
    Location
    Sun Valley, CA
    Posts
    122
    Quote Originally Posted by jp1300r View Post
    Its under the SS hat. Its doesn't look like its going to move though. May have to start cutting the shaft. Looks unuseable anyway.
    Thanks, I'm going to try & get it out. DO I slide the SS hat forward or backward???
    Any input on the empty water box???

  4. #4
    A smart admits!A wicked excuses!An idiot insists! mitsakosgt's Avatar
    Join Date
    Jun 2008
    Location
    GREECE ATHENS , NAXOS
    Posts
    2,691
    +1
    40
    Quote Originally Posted by srjrinc View Post
    Quote Originally Posted by jp1300r View Post
    Its under the SS hat. Its doesn't look like its going to move though. May have to start cutting the shaft. Looks unuseable anyway.
    Thanks, I'm going to try & get it out. DO I slide the SS hat forward or backward???
    Any input on the empty water box???
    You slide the driveshaft backward and the take off the c clip..Then you slide the hat forward while take the shaft out from the pump area...

  5. #5
    Mothman's Avatar
    Join Date
    May 2011
    Location
    West Texas
    Posts
    2,997
    +1
    1,478
    I'd toss that shaft. It'll ruin your day when you get it running and it twists in half from rust penetration.

  6. +1 by:


  7. #6
    GGG's Avatar
    Join Date
    Sep 2009
    Location
    Jersey Shore
    Posts
    2,830
    +1
    258
    your gonna have to cut the "hat" off theres no way it will just slide

  8. #7
    srjrinc's Avatar
    Join Date
    Aug 2012
    Location
    Sun Valley, CA
    Posts
    122
    Got it! Thanks!!! Any thought on the empty water box?????????

  9. #8
    Banned User
    Join Date
    Aug 2011
    Posts
    5,049
    +1
    238
    You do realize what it's going to cost to rebuild that ski to specs or better correct?

  10. #9
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Even though its called a waterbox, there is no water in it when the ski is not running......The waterbox is just a muffler, gets water from the exhaust manifold...The manifold gets water form the IC...the IC gets water from the pump, only when the motor is running...

  11. #10
    srjrinc's Avatar
    Join Date
    Aug 2012
    Location
    Sun Valley, CA
    Posts
    122
    Quote Originally Posted by Danny View Post
    Even though its called a waterbox, there is no water in it when the ski is not running......The waterbox is just a muffler, gets water from the exhaust manifold...The manifold gets water form the IC...the IC gets water from the pump, only when the motor is running...
    Wow. THANKS for the info. I thought it worked like the 2 strokes. This is why I bought this thing! yo learn the 4 stroke ways! !!

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. No Water Box? GP1200
    By joezap in forum Yamaha Old School Skis
    Replies: 5
    Last Post: 07-15-2009, 12:40 AM
  2. no water box?
    By onebadsho in forum Kawasaki PWC Performance (4-stroke)
    Replies: 1
    Last Post: 05-15-2009, 11:04 PM
  3. Water in CDI box
    By 1hotpotato in forum Polaris Open Discussion
    Replies: 5
    Last Post: 08-27-2007, 07:36 PM
  4. Water in CDI box
    By jonjonwells in forum Polaris Open Discussion
    Replies: 3
    Last Post: 07-09-2007, 08:21 AM
  5. Anyone try a TDR water box in a GPR
    By yamadoo2 in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 05-23-2006, 03:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •