Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1

    Solenoid clicking slt780

    after riding for a while then turning off ski, when i go to restart the solenoid just clicks. let it set for awhile it will then kick in starter.

    the fuse is removed for MFD display because of other issues of limp mode.

    ski runs fine otherwise except at low idle it tends to load up, have to rap throttle to run otherwise it bogs out.

    any suggestions?
    Last edited by K447; 09-07-2013 at 05:58 PM.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Welcome

    Is the click a small click from the electrical box, or a heavy clunk from the front of the engine?

    If it is a small click from the electrical box;

    Remove and clean both ends of both battery cables.

    If still no good, remove and clean both ends of starter cable.

    OR replace the start solenoid.


    If ti is a heavy clunk, observe whether the engine shudders or the crank shaft (or drive shaft) moves at all when the clunk happens.

  3. #3
    just a small click from cdi box. wouldn't start on the lake. pulled it to shore checked out some threads, walked back down now starter turns over, no click

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by speedy9913 View Post
    just a small click from cdi box. wouldn't start on the lake. pulled it to shore checked out some threads, walked back down now starter turns over, no click
    Well then, do this;

    Quote Originally Posted by K447 View Post
    ...
    Remove and clean both ends of both battery cables.

    If still no good, remove and clean both ends of starter cable.

    OR replace the start solenoid...
    Regarding the MFD, it is best to unplug the connector from behind the display. Sometimes a dead MFD will cause strange issues with the ignition. Apparently not affecting your machine, but easy enough to do the disconnect.

  5. #5
    ok, held starter button down, tapped cdi by selinoid, starter kicked in

  6. #6
    Echo's Avatar
    Join Date
    Aug 2013
    Location
    Tarpon Springs FL
    Posts
    383
    +1
    33
    Could be u moved something just enough. Sounds like solenoid to me tho. I literally just hitched a ride with seatow for the same thing. Mine sems to be the starter tho. I say this cause I am using a volt meter to determine where power is. You could do the same thing. See if u have power on the starter side next time it does it.

  7. #7
    don't want to sound stupid, but exactly where is the starter, front of engine, port side?

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by speedy9913 View Post
    ... where is the starter? front of engine, port side?
    Starter motor is bolted to the left side of the engine crank case, down low, just behind the flywheel housing.

  9. #9
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,599
    +1
    1,276
    Quote Originally Posted by speedy9913 View Post
    ok, held starter button down, tapped cdi by solenoid, starter kicked in
    Sounds like the solenoid needs to be replaced.

    Once a solenoid becomes intermittent (works sometimes, does not work sometimes) that means the metal electrical contacts inside are failing and it is no longer reliable.

  10. #10
    thks, will check on new selinoid.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 07-09-2014, 02:17 PM
  2. 97 seadoo xp starter solenoid click
    By OC seadoo in forum 2-Stroke Performance
    Replies: 13
    Last Post: 05-22-2014, 11:18 PM
  3. solenoid clicking
    By josh22 in forum Polaris Open Discussion
    Replies: 6
    Last Post: 08-04-2011, 11:57 PM
  4. 97 SPX Solenoid clicks but starter does not run
    By ARBEE in forum 2-Stroke Performance
    Replies: 2
    Last Post: 08-04-2011, 10:54 AM
  5. Solenoid just clicks
    By gerhand44 in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 10-24-2006, 02:04 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •