Results 1 to 3 of 3
  1. #1

    loading up at low rpms

    i have a 97 slt780 which seems to be loading up at an idle to about quarter throttle, from there to full throttle runs great. going to change out fuel filter, any other suggestions ?

  2. #2
    bowsniper's Avatar
    Join Date
    Aug 2008
    What kind of plugs are you running ? Have you done anything recently to the ski? Did this problem just start recently ? Are the plugs old? Are. The carbs rebuilt? Fuel system redone with filters and lines? ..are the plugs actually loading up with carbon the ski just fussy until you get going fast?

  3. #3
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada
    You already have some answers in your previous thread;

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Problem with 96 GTX- low RPM's under load
    By Humbucker427 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 07-08-2009, 03:13 PM
  2. 2002 Virage - low RPM under load - HELP !!
    By sklinicki in forum Polaris How To & FAQs
    Replies: 19
    Last Post: 06-15-2009, 08:00 PM
  3. 06 rxp low rpm
    By rxpenpastu in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 07-21-2006, 02:25 PM
  4. Low RPM Issue
    By xenonx in forum 4-Tec Performance
    Replies: 11
    Last Post: 06-19-2006, 03:19 PM
  5. New 04 RXP Low RPM & Speed
    By RXP04 in forum 4-Tec Performance
    Replies: 0
    Last Post: 07-02-2005, 09:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts