Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    Shaft Splines and wear ring on a 1200XLT 1999 (Help)

    Hi All, I need your help if you don’t mind

    I Bought a 1200Xlt and yesterday I took it out for a spin.. after 1hr of riding I stopped to take a swim, till now all went well… however going back to shore the engine was revving but could not get this to plane… top speed was 10 mph I noticed that something was slipping like a clutch in a car.

    Today I removed the jet unit to inspect and here is what I found… Photos to help me explain myself more..

    The shaft Splines do look like shit!
    The ware Ring (the plastic one) has some scratches that you can easily feel and see…
    The Impeller has some sort of dents on all trialing edges of the blades…

    Can you please advise a way forward?

    I honestly think that I don’t need to change the impeller as this was doing just fine before the shaft gave way right?
    Also can the ware ring be replaced on its own? And still in place as in the photo? I don’t think this is an expensive part

    I have some good mechanical knowledge but it’s my first time working on a Ski so any input is much appreciated.

    Tx
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image5.jpg 
Views:	78 
Size:	85.6 KB 
ID:	312952   Click image for larger version. 

Name:	image4.jpg 
Views:	79 
Size:	87.8 KB 
ID:	312950   Click image for larger version. 

Name:	image3.jpg 
Views:	72 
Size:	76.5 KB 
ID:	312948   Click image for larger version. 

Name:	image1.jpg 
Views:	69 
Size:	78.0 KB 
ID:	312949   Click image for larger version. 

Name:	image8.jpg 
Views:	75 
Size:	67.8 KB 
ID:	312951  


  2. #2
    mudslanger's Avatar
    Join Date
    Jul 2010
    Location
    Huntsville Al
    Posts
    1,326
    +1
    49
    I can't tell much about the splines from the pics but if they have been slipping in the mid shaft then both should be replaced. The prop is the stock prop and the wear ring is aftermarket and can be replaced. You may need to seal the pump shoe if it hasn't already need done and if it has you may need to redo it if it wasn't done wright. You should consider replacing the prop it has a lot of cavitation burn on it and may not have the clearance it suppose to.

  3. #3
    Quote Originally Posted by mudslanger View Post
    I can't tell much about the splines from the pics but if they have been slipping in the mid shaft then both should be replaced. The prop is the stock prop and the wear ring is aftermarket and can be replaced. You may need to seal the pump shoe if it hasn't already need done and if it has you may need to redo it if it wasn't done wright. You should consider replacing the prop it has a lot of cavitation burn on it and may not have the clearance it suppose to.

    Hi. Mudslanger,

    Thanks for your reply,

    All I can say is that something was slipping... Do you think that it's the mid Shaft? are these things expensive? I will change the wear ring for sure, but I dont think I will changed the prop, just for the simple reason this was working fine, pick up speed was ok and top speed was 55mph indicated.

    Is it hard to remove the mid shaft? do I need to remove the exausht ?


    Do you recomend someone with good prices around? I also plan to re-build the carbs as they tend to bog a bit on pick up but then all fine.. any suggestions wellcome as I am a new guy on these things...


    Thx

  4. #4
    Your splines are stripped and wear ring is fine, thats common for it to be that way(plastic Liner). When you switch out the plastic liner they are thicker than norm and when you first ride it the prop wears itself into the ring which creates those scratches or scuffs you see. The prop where its pitting could be old age corrosion or caviation burns. If you want a night and day difference the solas concorde 11/14 is the prop for that boat. Do the intake grate and pump seal kit and it will be a totally different ski.
    I have the shafts for a 2001 xlt but they are slightly different in length. If you use both the intermediate shaft and main shaft of that year they will fit into you ski no problems. The total length is the same they just shortened the inside length of the intermediate and increased the length slightly of the main that year. I would do 250 shipped for both if you want them. They are very close to new, maybe only 20 hrs on them before I had parted out the ski, and also they are both OEM!
    PM me if you want them.

  5. #5
    Hi Scittb

    Sent you a PM did you receive it??? as I cant find this in my sent folder on GH

    thx

  6. #6
    Hi,

    Finally I found some time and reassembled this. New shaft coupler,seals,bearings etc...

    Now I need to start working on the drive shaft and seals... hopefully by end of this week.

    So back to my question, I can’t figure out from where this bolt is missing!
    Click image for larger version. 

Name:	2013-11-18 19.33.36.jpg 
Views:	50 
Size:	58.7 KB 
ID:	318734Click image for larger version. 

Name:	2013-11-18 19.33.19.jpg 
Views:	51 
Size:	77.4 KB 
ID:	318735

    This Bold is exactly the same as the one on the PTO side holding the stinger with the engine, just above the temp sender.

    I have everything in place bolted and tight! But this one seems to have fallen out of the sky :O I checked and rechecked but everything is looking in place.

    Any help ?

    Tx

    Mic

  7. #7
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,800
    +1
    449
    its a rear muffler stay bolt... for the bracket on the rear of the pipe

  8. #8
    Hi WFO.

    See Photo.... please Click image for larger version. 

Name:	Stinger.jpg 
Views:	55 
Size:	41.5 KB 
ID:	318792

  9. #9
    Hi WFO.

    See Photo.... please Click image for larger version. 

Name:	Stinger.jpg 
Views:	50 
Size:	35.5 KB 
ID:	318793

  10. #10
    Happily Self-Employed WFO's Avatar
    Join Date
    Nov 2005
    Location
    Houston, Texas
    Posts
    12,800
    +1
    449
    IMO its one of the bolts that go into #20

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Impeller and wear ring on 03 gp1300
    By Waveflyer 90 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 05-20-2016, 02:08 PM
  2. Thoughts on this Impeller and Wear Ring
    By Yanksfan in forum 4-Tec Performance
    Replies: 8
    Last Post: 12-29-2015, 12:54 PM
  3. '11 GTI 130SE needs advice on impeller and wear ring
    By jm_obrien in forum 4-Tec Performance
    Replies: 12
    Last Post: 09-11-2015, 01:36 PM
  4. Replacing Impeller and wear ring on 2005 Sea Doo GTX SC 185
    By Kirk1964 in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-11-2014, 12:30 AM
  5. Replies: 6
    Last Post: 07-05-2012, 07:15 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •