Results 1 to 4 of 4
  1. #1
    thetolleyman's Avatar
    Join Date
    Jul 2010
    Location
    Williamsburg, VA
    Posts
    562
    +1
    2

    STX 15F, two fuel pumps in one week? Any one else have this?

    I've had two fuel pumps quit in less than two hours of run time. I've obviously got another problem. Anyone run into this before.

    First time I completely drained the fuel tank, making sure to get all the debris out. Replaced fuel pump motor and pre-filter.


  2. #2
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    They just stop working all together or what ?

  3. #3
    My name is Sean and I am addicted to STXs smokeysevin's Avatar
    Join Date
    May 2008
    Location
    Houston
    Posts
    4,485
    +1
    320
    Have you checked the function of the pump out of the can? I had a pump that had loose terminals in the plug itself on the inside of the fuel pump housing. I ended up having to replace the plugs and bend the contacts to get it to work. I would bet that is the problem.

    Sean

  4. #4
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,158
    +1
    600
    explain the symptom of the pump failure , whats the ski doing

    u sure its not a stuck pressure reg causing dead head and killing the pumps ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Stx 1100 DI fuel pump
    By WooW22 in forum Kawasaki Projects
    Replies: 0
    Last Post: 07-01-2016, 10:03 PM
  2. 2006 STX 15F No Fuel Level on DASH ?
    By shadetreejerry in forum Kawasaki Open Discussion
    Replies: 4
    Last Post: 08-04-2013, 12:14 PM
  3. Kawasaki STX-15F 2008 fuel warning light on
    By mcmurtrey in forum Kawasaki PWC Performance (4-stroke)
    Replies: 4
    Last Post: 08-03-2011, 11:33 AM
  4. WTB wanted fuel pump 2001 stx 1100 di fuel pump
    By onefastgpr619 in forum Kawasaki Classifieds
    Replies: 4
    Last Post: 07-07-2010, 09:41 PM
  5. Fuel pump in gp1300r not working?
    By wildman326 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-20-2006, 08:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •