Results 1 to 3 of 3
  1. #1

    1996 Seadoo GTX starting problems

    Hello newbie here. I just recently bought a 96 Seadoo GTX and was having problems starting up. At first I thought it was just a dead battery because when I went to start it the starter would engage but would not turn over. I ended up buying a new battery got it fully charged and it does the same thing. Now here is what is completely baffling me. It took the plugs out to check them and for shits and giggles I went to turn it over and it turns over just fine. I put the plugs back it and " click , click " same thing as before starter engages but won't turn over. What could be causing this to happen? What can I do to fix this?

  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada
    When you cranked it with the spark plugs out did any liquid spew from the spark plug holes?

  3. #3
    XcrabnutzP's Avatar
    Join Date
    Aug 2013
    Winter Haven, FL
    The cylinders might be flooded, hence the reason it turns over with the plugs out. Shutting it off at full throttle and coasting in is an easy way to flood the crank case and cylinders with fuel resulting in Hydro lock when you go to start it the next time. Always remember to ground your plug wires when turning it over with the plugs out or you could have a nice fireball coming out of your hull!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1996 Seadoo GTX hard to start
    By svt killer in forum 2-Stroke Performance
    Replies: 4
    Last Post: 06-23-2013, 05:03 PM
  2. 1996 Seadoo Gtx starter removal and starting issue
    By svt killer in forum 2-Stroke Performance
    Replies: 0
    Last Post: 06-02-2013, 07:45 PM
  3. weird 97 seadoo gtx starting problem
    By stevemacd in forum 2-Stroke Performance
    Replies: 4
    Last Post: 06-21-2012, 12:14 PM
  4. 97 gtx start problems
    By bigh62 in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 07-28-2007, 12:32 PM
  5. 1996 WaveRaider 700 Starting Problem
    By in-mn in forum Yamaha Old School Skis
    Replies: 3
    Last Post: 06-21-2007, 01:18 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts