Page 1 of 5 1 2 3 ... LastLast
Results 1 to 10 of 49
  1. #1
    DoubleTap's Avatar
    Join Date
    Jun 2011
    Location
    Cape Coral, FL
    Posts
    195
    +1
    60

    Dealer can't fix my 300x. Need help!

    I have a 2011 300x the ski hits a limiter at 3500 and will not go any higher. No codes. They have replaced the fuel pump and have also tried a new computer and throttle position sensor. The ski has 190 hours exhaust filter is fine and the supercharger belt was replaced 20 hours ago. They have been working with Kawi and can't figure the problem out.


  2. #2
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Is it making boost ?
    New plugs installed ?
    Leak down test done ?
    Compression test done ?
    Scom installed ?
    Any codes ?
    Need info man.

  3. +1 by:


  4. #3
    DoubleTap's Avatar
    Join Date
    Jun 2011
    Location
    Cape Coral, FL
    Posts
    195
    +1
    60
    Makes full boost up to 3500 rpm then it hits a limiter
    New plugs
    They did a leak down,compression,fuel pressure test was fine
    They also said the supercharger and exhaust filter were fine
    Bone stock with warranty
    no codes

  5. #4
    Banned User
    Join Date
    Jul 2013
    Posts
    424
    +1
    40
    Check and double check all your electrical connections, start at the battery

  6. #5
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    how can it possibly make full boost at 3500rpm? ski doesnt start to make boost until 5000rpm approx

  7. #6
    DoubleTap's Avatar
    Join Date
    Jun 2011
    Location
    Cape Coral, FL
    Posts
    195
    +1
    60
    The dealer told me it was a 3500 shutoff? I never noticed the rpm. It might get higher on take off but if you leave it floored once you are on plane it kicks on and off at 30mph. On take off boost jumps up like normal. They said they checked every connection? They have been working on the ski over a week.

  8. #7
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    sorry not enough info for us to use our crystal balls

  9. #8
    Banned User
    Join Date
    Jan 2009
    Location
    LA/oc
    Posts
    3,911
    +1
    129
    Sounds like your using the yellow key

  10. #9
    DoubleTap's Avatar
    Join Date
    Jun 2011
    Location
    Cape Coral, FL
    Posts
    195
    +1
    60
    No worries, thought someone might have had a similar issue.
    I'll let Kawi sort it out.


    They only give the yellow key to you guys in California

  11. #10
    Echo's Avatar
    Join Date
    Aug 2013
    Location
    Tarpon Springs FL
    Posts
    383
    +1
    33
    It is under warranty maybe you can get a new ski

Page 1 of 5 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. yamaha dealer can't fix my waverunner
    By wavejunky22 in forum Yamaha PWC Performance (2-stroke)
    Replies: 19
    Last Post: 04-08-2014, 06:19 PM
  2. Dealer keeps F'king up my 300 need help!
    By Kawabunga in forum Kawasaki PWC Performance (4-stroke)
    Replies: 70
    Last Post: 09-21-2013, 08:09 AM
  3. Can I fix my lanyard switch?
    By thehemi in forum Polaris Open Discussion
    Replies: 5
    Last Post: 05-31-2009, 03:46 PM
  4. i can't put it back...need help
    By pet in forum 4-Tec Performance
    Replies: 20
    Last Post: 08-07-2007, 08:25 PM
  5. Flipped my ski, need help (was "danger")
    By smc in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 09-03-2006, 08:26 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •