Results 1 to 9 of 9
  1. #1
    Seadoos and Syrup Jec's Avatar
    Join Date
    Aug 2013
    Location
    Bethany, CT
    Posts
    81
    +1
    2

    Gti se not reaching 7000 rpm

    Today I rode my gti se and it would not get above 7000 rpm when on the weekend it was at 7200 rpm. Could it be the hot humid air of if there's too much oil? (Just added a quart because it was low)


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Did you check the oil after a ride with 30 seconds of idle then sit for 30 seconds then check it?
    You probably just over filled your ski. That's your loss of rpms.
    If its over full and your running wot chances are its pushing oil into your air intake.

  3. #3
    Swedish Viking Craigo's Avatar
    Join Date
    Jun 2008
    Location
    Seattle
    Posts
    1,367
    +1
    62
    Quote Originally Posted by Jec View Post
    Today I rode my gti se and it would not get above 7000 rpm when on the weekend it was at 7200 rpm. Could it be the hot humid air of if there's too much oil? (Just added a quart because it was low)
    It could be a couple of things - but you should replace your spark plugs. I once had the same issue and new plugs fixed the problem.

  4. #4
    Seadoos and Syrup Jec's Avatar
    Join Date
    Aug 2013
    Location
    Bethany, CT
    Posts
    81
    +1
    2
    Ok I'll check it again. Is there anyway of taking oil out without a oil sucker?

  5. #5
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    No. You need it to suck some out. Your also going to need it for oil changes.

  6. #6
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Did taking oil out fix your low rpm issue??

  7. #7
    Seadoos and Syrup Jec's Avatar
    Join Date
    Aug 2013
    Location
    Bethany, CT
    Posts
    81
    +1
    2
    I don't know yet. Haven't brought it to the lake. Maybe tommorow.

  8. #8
    Wear ring and impeller.

  9. #9
    Mothman's Avatar
    Join Date
    May 2011
    Location
    West Texas
    Posts
    2,996
    +1
    1,477
    Quote Originally Posted by kwtony View Post
    Wear ring and impeller.
    That wouldn't cause an rpm drop. If cavitating, it would cause an rpm gain and speed loss.
    I overfilled mine once, to the top of the bend, and lost 2-300rpm.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. GP 1300 not reaching max rpms. bogs out at 42 mph
    By Binihana in forum Yamaha How To & FAQs
    Replies: 17
    Last Post: 07-13-2011, 01:27 AM
  2. 03 msx 140 not reaching full rpm??
    By REG-DOG in forum MSX/Matrix
    Replies: 6
    Last Post: 08-10-2010, 08:24 AM
  3. not reaching top rpm
    By exy2222 in forum 4-Tec Performance
    Replies: 17
    Last Post: 12-14-2009, 01:52 PM
  4. Wet Plug 96 GSX - Not Reaching MAX RPMS
    By Seapoo in forum 2-Stroke Performance
    Replies: 23
    Last Post: 08-24-2009, 05:40 PM
  5. 96 XP not reaching full RPMS consitently
    By DarthAWM in forum 2-Stroke Performance
    Replies: 14
    Last Post: 04-17-2008, 10:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •