Results 1 to 2 of 2
  1. #1

    polaris 2002 1200 injection jet ski start up

    I have a 2002 polaris xti 1200 virage... It takes at least ten minutes to warm up and stalls repeatedly until it warms up. Once it is warm it rides beautifully. It only has 95 hours. I use startron additive according to the directions and prestone oil marine brand. I have changed the plugs and over the three years i have owned this machine i have maintained it according to manual. This is a recent issue as the first two years it started right up and after about two minutes at idle speed i was able to go full throttle.

    I need some advice on how to correct this problem.



  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    near Toronto, Canada

    My initial suspicion would be the TPS sensor on the rear end of the throttle body shaft.

    Do you have another Ficht machine you can swap parts with for testing?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Polaris Virage 1200 TXi tough cold starts
    By coolgary76 in forum Polaris How To & FAQs
    Replies: 7
    Last Post: 11-22-2013, 02:35 PM
  2. Replies: 10
    Last Post: 09-26-2010, 08:13 PM
  3. Polaris SLXH `98 1050CC Jet-ski w/Trailer ONLY 56 HOURS
    By CrYsTaLiZeD in forum Polaris Classifieds
    Replies: 0
    Last Post: 05-30-2009, 04:05 PM
  4. my jet ski starts but only when i prime it
    By mushroomhead8 in forum Polaris Open Discussion
    Replies: 9
    Last Post: 12-13-2008, 01:11 AM
  5. Polaris Huricane New OEM Jet Ski PWC Cover
    By la90043 in forum Polaris Open Discussion
    Replies: 10
    Last Post: 03-05-2008, 11:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts