Results 1 to 4 of 4
  1. #1
    usamps's Avatar
    Join Date
    Jul 2012
    Location
    fayetteville, nc
    Posts
    84
    +1
    1

    7850 rpms....tooo low!

    i have a 05 rxp. i installed a riva stage one kit, rive opas block offs, checked sc slip at around 90 inch lbs, . When i first got the ski i would run consistently 8100. I had a hose clamp blow off that ran to the ride plate and dumped all my coolant. The ski of course stopped and started runnuing hot. i had the ski towed back to the dock. i found the blown off hose pretty quick when i got home. it seemd every since that happened i have lost a few hundred rpms. do you guys have some ideas that i could check . i lso had a chunk of fiberglass on the underside knocked out when i bought it i repaired it with mat and fiberglass. i then painted the bootm of the hull with auto ppg paint and sprayed it with ppg clear. it lasted about 3 months before it started peeling, could this cause rpm drop from the drag on the bottom?


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472

    Cool

    Have you done a compression check on it or leak down test on the motor?
    She may have cooked a little to long..

    Is your oil level right? Over full oil will also cause rpm loss.
    Fresh set of spark plugs?
    Start with the easy cheap stuff 1st.

  3. +1 by:


  4. #3
    usamps's Avatar
    Join Date
    Jul 2012
    Location
    fayetteville, nc
    Posts
    84
    +1
    1
    i did a compression test the cylendars were all good. i have 40 plus hours on the ski since the. it runs fine, if it would have had motor problems it would shown by now. it runs right at 68. i repalced plugs since then and oil is dead center of the stick.

  5. #4
    98gsxl951's Avatar
    Join Date
    Jul 2008
    Location
    On my ski, on the CT river
    Posts
    879
    +1
    3
    whats the temperature out side when you are seeing 7850 ? the hotter the air the more rpms you lose. but this time of year i would think heat soak would be minimal.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. grate,7850 rpm,rear air?
    By jake2582 in forum 4-Tec Performance
    Replies: 1
    Last Post: 07-15-2009, 09:52 AM
  2. maxing out at 7850 rpms
    By newskiier in forum 4-Tec Performance
    Replies: 23
    Last Post: 07-25-2008, 03:11 AM
  3. Replies: 3
    Last Post: 11-08-2007, 05:06 PM
  4. RPM's LOW...Need suggestions
    By BLACKSTI in forum 4-Tec Performance
    Replies: 4
    Last Post: 09-04-2007, 02:55 PM
  5. RPM's Low?
    By 98Hawk in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-15-2006, 06:40 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •