Results 1 to 6 of 6
  1. #1
    Banned User
    Join Date
    Mar 2013
    Posts
    73

    Msx 150 will not throttle up idles fine need help

    I have two msx 150 the one will idle all day but will not throttle up, has service engine light. Swap the map sensor did not work, swap the ppu nothing, ebt will move if i try to start and i can see the ebt moving when i pull the throttle but if i start it the ebt will not move????? What is the problem...
    Last edited by chc3; 09-14-2013 at 04:46 PM.


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,593
    +1
    1,275
    Does the other machine run properly?

  3. #3
    Banned User
    Join Date
    Mar 2013
    Posts
    73
    Yes other machine runs fine... I think i figured it out, I swap the exhaust temp sensor now it works fine again. that was weird that sensor keeps the throttle from moving.

  4. #4
    Iantryinit's Avatar
    Join Date
    May 2013
    Location
    Manitoba, Canada
    Posts
    48
    +1
    1
    Is the temp light on?

  5. #5
    Banned User
    Join Date
    Mar 2013
    Posts
    73
    Not at first just check engine after a minute then temp light only would idle replace the water temp sensor nothing replaced the exhaust temp sensor and bingo no overheat light and the ski would rev up..
    Last edited by chc3; 09-19-2013 at 04:31 AM.

  6. #6
    ripcuda's Avatar
    Join Date
    May 2010
    Location
    Newman Lake, WA
    Posts
    2,389
    +1
    166
    The exhaust thermo switch (sensor) will trip an overheat and force a rev-limited limp mode. So yeah... it won't rev up. You can unplug the single wire to it to test and see if it's tripping and causing the condition. Unplugged, the ECU thinks all is good... so if you unplug it and the condition goes away... then that's your cause. Make sure you are in fact not overheating in the exhaust. That you have proper freshwater flow from the oil tank to the exhaust manifold... and a small T'eed line to the exhaust water injector orifice is clear and flowing too. These all work to keep the exhaust temps in check.

    Good luck finding an SIFB. They are pretty rare. Martos was selling some aftermarket ones... at a steep premium. Otherwise it's a used one off a parted out ski. You might contact Randy at WeberPower (dot com) and see what he might have.

    Cheers!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 9
    Last Post: 06-24-2015, 03:55 PM
  2. 2004 MSX 150 will not stop running
    By tsummerl in forum MSX/Matrix
    Replies: 11
    Last Post: 11-18-2012, 09:57 PM
  3. 94 Kawasaki ss idles but will not throttle up,..HELP PLEASE
    By Matthew in forum Kawasaki How To & FAQs
    Replies: 9
    Last Post: 06-27-2012, 06:55 AM
  4. MSX 150 Will Not go over 2900 RPMS
    By rtburns in forum MSX/Matrix
    Replies: 3
    Last Post: 07-01-2009, 10:47 PM
  5. 2004 MSX 150 will not stop running
    By tsummerl in forum Polaris Open Discussion
    Replies: 4
    Last Post: 11-13-2008, 05:11 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •