Results 1 to 4 of 4
  1. #1

    Seadoo LRV Problems

    Hi I have a Seadoo LRV 951 With the direct fuel injected engine. I used it in the begginning of this year and it ran fine. Now It only starts when I spray gasoline in the cylinders. And it also Only runs 40mph not 50mph as it used too. Any ideas on what could be wrong?

  2. #2
    Myself's Avatar
    Join Date
    May 2007
    North Central Arkansas
    Sounds like your fuel pump is bad. You will need to hook up a pressure gauge inline so you can view fuel pump pressure output at startup and while running. Could just be old nasty fuel filters (1 inline and 2 in the tank on the module.)

  3. #3
    wotxxxsd's Avatar
    Join Date
    May 2012
    +1 on filters

  4. #4

    Join Date
    Feb 2012
    Mackay Qld Australia
    Pump or filter, most likely pump as there is next to no fuel flow required to start the engine so therefore its most likely a lack of pressure causing low fuel amount through injectors

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 Seadoo RXP problem
    By mustbenu in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-01-2011, 10:03 PM
  2. 93 seadoo xp problems
    By b93xp in forum 2-Stroke Performance
    Replies: 6
    Last Post: 06-17-2008, 11:07 PM
  3. Seadoo Washer Problem
    By Penguin in forum 4-Tec Performance
    Replies: 4
    Last Post: 05-01-2008, 06:01 PM
  4. Seadoo sp PROBLEMS!!!
    By QuickMick in forum Yamaha PWC Performance (2-stroke)
    Replies: 15
    Last Post: 06-29-2006, 09:56 PM
  5. Seadoo GTX problem Need help!
    By DeeGee in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 06-17-2006, 11:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts