Results 1 to 7 of 7
  1. #1

    2010 RXT X - Bad vibration when turning at 6000 ish RPMs

    I bought a 2010 RXT X 260 used with 54 hours on it 2 years ago. It has the BEST Warrenty till 2015. Since the day i got it i have noticed a pretty bad vibration at about 6000 rpms but only when the handlebars are turned slighty. The ski now has 117 Hrs on it. I had it up to my dealer getting the supercharger done and oil change at the start of this season and they checked a few things that it could be with no luck. They said they need to take it for a water test but where to busy at the time, which was fine. I am taking it back to the dealer next week for them to have a better look at it and do a water test to hopefully narrow done this vibration.

    Has anybody else experienced anything like this before?

    Thanks Sledaholic


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    The 10 tx skis have junk drive shafts..
    They are very known to strip out.
    As far as your vibration I would check the impeller.

    Welcome aboard the Hulk!!!!

  3. #3
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    +1 on checking the pump/driveshaft. I would have them check motor mounts too. The bases are cast from China and I had some corrosion on mine after a couple seasons. You could have a loose one.

  4. #4
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,851
    +1
    742
    I guarantee your engine is out of alignment and has been since day one! Myself and 7 other 2010 TX owners have had to realign our engines to the pump. I have the full alignment kit and have it loaned out as we speak.

    The original 2010 drive shaft & floating ring setup is junk. Lots of vibration, splines stripped, etc. etc.

    You NEED a 2011-2012 c clip drive shaft and all of its components and a complete realignment.

    I bet your wear ring is torn up and has uneven wear also.

    Just do a search and you will find lots of info about this subject.

    Read this entire thread http://www.greenhulk.net/forums/showthread.php?t=205100

    Don't be surprised if your dealer doesn't know a damn thing about this either!!!!

  5. #5
    Thanks for the replays!
    Do you think any of this will be covered under warranty? What will it cost to upgrade to the 2011 driveshaft set up and realign the motor?

    Thanks

  6. #6
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    Some dealers will do it under warranty. Mine wouldn't do it till something failed(never did). Around $600 for parts, not sure on labor. I borrowed jpt's tools and did it myself.

  7. #7
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    If they won't doo it till it fails then take her out and doo some racing... Those splines are surely going to fail... Sounds like your lucky to have gotten 117+ hours out of the shaft. Many many others have failed at around 50+- hrs..
    Of course try to get them to doo the right thing and get it replaced prior to it failing.
    But its surely going to fail before your warranty is up in 2015..
    If 1 dealer doesn't want to replace it call a few others..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. FZS Riva Stage 3--Loud vibration when turning hard
    By LamaYamaha in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 08-05-2011, 05:22 PM
  2. 2010 RXT-X260 Bad Support Plate Formed Seals
    By immred in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-25-2011, 09:35 PM
  3. Yamaha FX SHO litle vibration and noise at 3000-4000 rpm
    By paul18187 in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 08-12-2010, 11:32 PM
  4. 2010 RXT-X at Bert's in Los Angeles
    By jake57 in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 02-04-2010, 05:58 PM
  5. Strange squeaking noise when turning at speed! Help
    By CarFanatic in forum 4-Tec Performance
    Replies: 9
    Last Post: 05-29-2007, 08:22 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •