Results 1 to 5 of 5
  1. #1
    g550plt's Avatar
    Join Date
    May 2013
    Location
    Boynton Beach, FL
    Posts
    130

    Question about Exhaust Valve in 4/2006 motor?

    My 05 RXP dropped an exhaust valve when it was about a year old..at 26 hours. The engine was replaced under warranty with a new short block on 4/26/2016... You guys think it still has the flawed exhaust valves? I figure the only way to be sure is to open it up.. Just wondered what you guys would say


  2. #2
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    06 was the changeover year. I have an 06 head with the correct valves. You have to look @ the stem and check the numbers. Without doing that you have a 50/50 chance of having the same crap valves

  3. #3
    Quote Originally Posted by g550plt View Post
    My 05 RXP dropped an exhaust valve when it was about a year old..at 26 hours. The engine was replaced under warranty with a new short block on 4/26/2016... You guys think it still has the flawed exhaust valves? I figure the only way to be sure is to open it up.. Just wondered what you guys would say
    Pull the valve cover off. Take a mirror and look around the top of the valve stems. If they have a 72 prefix on the part number they are OLD STYLE valve that had premature valve failures. if they have 75 prefix part number.. They are New Style UP Dated valves. Now this is considering that the engine mfrger used SEADOO O.E. VALVES?

  4. #4
    g550plt's Avatar
    Join Date
    May 2013
    Location
    Boynton Beach, FL
    Posts
    130
    I assume it's stock.. It was a warranty engine swap.. Funny that after talking to both dealers in my area .. They act like it's just an anomaly due to poor maintenance.. Pretty funny for having that failure at 3 months old and 26 hours..

  5. #5
    Quote Originally Posted by g550plt View Post
    I assume it's stock.. It was a warranty engine swap.. Funny that after talking to both dealers in my area .. They act like it's just an anomaly due to poor maintenance.. Pretty funny for having that failure at 3 months old and 26 hours..
    Sometimes if you admit there is a problem with a part?? it has a price attached to fix in. They have made a part improvement with the seadoo OE valve. but there are aftermarket valves too....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Some questions about aftermarket valves
    By cjo632racing in forum 4-Tec Performance
    Replies: 7
    Last Post: 08-21-2011, 07:02 AM
  2. Question about dropped valves.
    By GGG in forum 4-Tec Performance
    Replies: 8
    Last Post: 07-11-2011, 11:15 AM
  3. questions about power valve?
    By stingray152003 in forum Yamaha Open Discussion
    Replies: 8
    Last Post: 12-18-2008, 03:35 PM
  4. Question about reed valves
    By TwinRaiders in forum Yamaha Old School Skis
    Replies: 1
    Last Post: 10-09-2007, 06:36 PM
  5. Question about reed valves
    By TwinRaiders in forum Yamaha Open Discussion
    Replies: 0
    Last Post: 10-08-2007, 07:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •