Results 1 to 5 of 5
  1. #1

    Not getting fuel to carb...fuel gage and others not lighting up

    94 Kawasaki 750 ST I now get gas to the carb after cleaning out fuel lines but it will not idle, just revs real high. When I check the fuel filter there is no fuel in the filter but the ski starts

    I want to thank those that have helped me up to this point. I would be lost without your help.

    Thanks again,
    Last edited by rwpalmer100; 09-22-2013 at 11:33 AM. Reason: Progress

  2. #2
    DavidR's Avatar
    Join Date
    Jul 2013
    You really should put your 'ski in you signature line so we know what you are working on.

  3. #3
    Does your ski have Grey Tempo fuel lines?

  4. #4
    I am not sure. The fuel lines are normal black.

  5. #5
    ok, will do. makes sense

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 05-08-2013, 11:07 PM
  2. Getting ready for summer rear air and other questions
    By race24x in forum 4-Tec Performance
    Replies: 16
    Last Post: 03-01-2012, 10:12 PM
  3. 780 slt no start - fuel not getting into carbs
    By ktheake in forum Kawasaki Open Discussion
    Replies: 1
    Last Post: 12-29-2011, 08:46 PM
  4. 1990 Kawasaki JS 440 w/dual carbs not getting enough fuel???
    By lostcreek21 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 4
    Last Post: 10-01-2011, 12:02 AM
  5. 1992 sl 650 carbs not getting fuel, stumped???
    By hoopduerr in forum Polaris How To & FAQs
    Replies: 23
    Last Post: 08-16-2010, 01:32 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts