Page 1 of 2 1 2 LastLast
Results 1 to 10 of 11
  1. #1

    2000 GSX RFI died on me

    Good afternoon everyone!

    Yesterday my buddy was riding on my jetski while I was in my boat. He was trying to tow my other buddy water skiing. The water skier was new so it took him a bunch of times to get up. so they kept turning the ski on and off between tries so it wouldnt keep moving. I put a new battery in it and a new rectifier also new plugs last week. The ski was running mint then just cut out and died while on our way back. it had no juice at all. The ski wouldnt even beep when I put the key in and it was just completely dead. I thought this could have been the battery from all the starting but when we got back I had an extra charged battery and put that in and still nothing at all. No electrical power at all. What do you guys think it could be? I was thinking maybe a fuse?


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,517
    +1
    1,263
    check the main fuse in the rear electric box. make SURE you get the electrical box cover gasket back in place correctly

    if you have water in there check that gasket. It's often improperly installed. The gasket does NOT go in the cover, it goes around the perimeter of the box, then the cover slips on. A little silicon spray helps

  3. #3
    hmmm where is the fuse box located? i dont want to start pulling stuff apart... im sure its a pain to get too just like the rectfier

  4. #4
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,517
    +1
    1,263
    it's in the plastic box right in front of the rectifier. Three clips hold it in place. could be a problem getting it open..go slow do not break the clips..push down and get them past the catches first..if the cover is tough to get off..that's good..means it's sealed. So you have to overcome a little vaccum to get it off. Fuse is in a plastic holder that comes right off the solenoid.

    if you do not have a manual..get one.

    Until then you can locate most stuff on the GH parts diagrams here:

    http://partsfinder.onlinemicrofiche....artsfinder.htm

  5. #5
    Swapped out the 20 amps in the rear... one looked burnt out the other was good and still have nothing

  6. #6
    I have a manuel somewhere... forgot where I put it...

  7. #7
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,517
    +1
    1,263
    gee..something blew a big fat fuse and now with a replacement fuse...nothing.
    that
    is
    not
    good
    got a voltmeter?

    the fact that the replacement fuse didn't light it up means big trouble.
    trace the main power up to the mpem. Maybe the main plug is loose? That would be lucky.

    did the fuse look like it was melted..or vaporized(dead shorts vaporize the fuse)

    do not fall to temptation to the larger fuse.

    start at the battery and work your way in...wire can break under decent looking insulation

  8. #8
    the fuse didnt look too bad... it was black until about half way down on each of the metal parts... is there any other fuses that could effect the power?

  9. #9
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,517
    +1
    1,263
    should be some fuses on the skis mpem. it has a pretty big electrical connector or two on it. hard to miss.

    fusebox cover is rectangular and has clips to disengage it from the mpem body. might be some spare fuses in there. they are all marked.

  10. #10
    My connections to the battery are rusty, both the grounds and the connections... they have been like that for a while now... could that be the reason? I dont know why I would lose complete power from that

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2000 Seadoo Milenium gtx just died on me... Help please
    By Hexum in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 06-11-2013, 01:09 PM
  2. 2000 GSX RFI missing during operation?
    By donahue_85 in forum Sea Doo ECU Support
    Replies: 2
    Last Post: 10-05-2010, 06:49 PM
  3. FS Complete 2000 GSX rfi w/trailer for sale. Chicagoland area
    By Marioski in forum Sea Doo 2 Stroke Skis
    Replies: 1
    Last Post: 05-19-2010, 10:35 AM
  4. 2000 GSX RFI Exhaust Blown Out - Is this common?
    By zrtman in forum 2-Stroke Performance
    Replies: 1
    Last Post: 11-14-2009, 09:30 PM
  5. engine kinda died on me
    By jungo in forum 4-Tec Performance
    Replies: 1
    Last Post: 08-04-2005, 11:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •