Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1

    2002 virage,leaks water into hull, only when running.

    Leaking, forward part of drive shaft, between grease zirq and engine, thiers a plastic shroud, when running, water can be seen around it, is this a different seal, heard of a through hull bearing seal, but not going to do anything, till its too cold to ride. As for a shop to take it too, that's another headache!


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    That would be the through-hull bearing assembly seals that are leaking.

    See the Jet Pump section from my signature links for rebuild info.

    Inspect the impeller stator bearings while you have the jet pump apart.

  3. #3
    To change the "thru hull bearing" seals, im assuming everything from, from the back outlet, all the way to the back of the engine, in the drive train, has to come out? Ugh,, to do that, really need tech manual?

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Quote Originally Posted by elk river rascal View Post
    To change the "thru hull bearing" seals, im assuming everything from, from the back outlet, all the way to the back of the engine, in the drive train, has to come out? Ugh,, to do that, really need tech manual?
    See my signature links, Jet Pump section, for more details.

    The jet pump gets removed, then the drive shaft slides out. If you have done it once or twice, it takes maybe 20 minutes.

    Inside the hull, loosen and remove the hose clamp from around the front end of that stubby rubber 'hose' section. This clamp is the only thing holding the through-hull bearing in place. Now pull, wiggle and grunt until the entire through-hull bearing comes up and out.

    There is a plastic shroud over the coupler to the engine. Sometimes it is easier to remove the hose clamp for that and pry it off first. Sometimes it is easier to pry the whole thing off while still clamped to the through-hull bearing.

    The through-hull assembly will be quite greasy. Wipe it down as best you can for a better grip

  5. #5
    K447,,Thru hull bearing, is it a complete unit, with housing and grease zirq, or is it a seal inside? Think knowing what parts to get, maybe more difficult than job? Have looked at the parts breakdown, since im new to this, it appears to look like a plate of spaghetti. pulling the jet drive, and drive shaft, shed some light on what I need to replace? Think I better get a 30 pack, when I start this!

  6. #6
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Have you looked at my signature links, in the Jet Pump section?

    The through-hull assembly has two shaft seals inside the ends, and a pair of sintered metal bushings inside.

  7. #7
    Thru hull bearing does'nt appear worn? Could the seals be worn, inside the housing, not really visible, because of grease? Pulled drive shaft out, end splines looked good, part of shaft that rotates thru the bearing, wasn't worn and was smooth, the drive coupler has a rubber seal, but it doesn't look like the one on the parts schematic, or is it recessed? would it be best to just buy a bearing housing, that includes the seals? Impeller rotates smoothly, no blade contact with housing. Didn't plan on removing impeller? Good thing ive got plenty of time, to get it right.

  8. #8
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    On the Virage there is also a plastic 'housing' that the drive shaft runs through. The stubby rubber hose piece (10) attaches to this at the rear end.

    That plastic section is threaded into a retaining 'nut' underneath the hull, inside the pump tunnel. There is a round gasket/seal between the inside of the hull and the plastic housing.. See whether that plastic housing has loosened. Sometimes it can be tightened just by turning the entire through-hull assembly inside the hull.

    Items 11, 12 (the seal) and 13 in this diagram, although they are not really drawn to scale.
    Click image for larger version. 

Name:	7129B01.jpg 
Views:	30 
Size:	39.5 KB 
ID:	316257

  9. #9
    That rubber hose (item #10) seemed rock solid, should be able to get a new thru hull bearing assy, at the Polaris dealer, well stocked with parts, its adjacent to "Little sahara" popular 4 wheeler place in Oklahoma, is it really neccessary to use an alighnment tool, when installing the drive assy and jet drive? Thanks for the help!

  10. #10
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,596
    +1
    1,276
    Alignment tool is used to align the engine with the jet pump, not the jet pump with the engine. If the engine has not been removed then the alignment is still 'from the factory'.

    The alignment of the actual jet pump would only change if the pump base, which is sealed and bolted into the hull, was removed. The pump base defines the alignment of everything else.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Possible to leak water into hull from around drain plug area?
    By ptscon in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-13-2015, 12:58 PM
  2. 2002 virage I water coming out of the spark plug holes
    By seafirst in forum Polaris How To & FAQs
    Replies: 2
    Last Post: 02-27-2013, 08:25 AM
  3. Leaking coolant into hull RXTX 255
    By [email protected] in forum Sea Doo Open Discussion
    Replies: 8
    Last Post: 07-21-2012, 08:56 PM
  4. Leaked water into engine and very slow now
    By martinginnelly in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-09-2009, 01:48 PM
  5. 95 gtx leaking water in hull
    By SUCKMYWAKE in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-25-2007, 09:31 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •