Results 1 to 9 of 9
  1. #1

    driveshaft output seal leaking?

    losing all my engine oil out of my 4tec. where the driveshaft goes in I am not getting a seal. pulled it all out today and verified the seal is in good condition. it looks brand new still and has no damage. as best as I can tell there is a metal sleeve on the driveshaft that helps make a good seal. are there any tricks to get it to seal so I don't keep leaking oil into my ski?


  2. #2
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    Sounds like the rubber boot may have a hole in it or the bearing seperated...take the bearing/boot assembly off the PTO housing and inspect the boot for any kind of defects/damage..if that checks out then take the bearing out try taking a pair of channel locks and see if you can "snap" it back together...Also inspect the clamps to make sure they were tight also..

  3. #3
    the boot and everything is in good shape. it appears that the metal sleeve that butts up to the seal is not matching up to it. everything is tight and looks to be in good condition

  4. #4
    Moderator Snoman's Avatar
    Join Date
    Apr 2006
    Location
    South Chicagoland
    Posts
    14,688
    +1
    846
    did you check to see if the bearing pulled??they are known for this..like i suggested before...take a channel locks and squeeze it together and see if it "clicks" back in...

  5. #5
    will give it a shot in the morning and see

  6. #6

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    3,447
    +1
    653
    Check filter for metal shavings...from possible bearing failure?

  7. #7
    No shavings. I had to pull the motor so just thinking I didnt get it lined up

  8. #8
    Sometimes the metal piece on the PTO bearing separates and needs to be mated together.
    It happened to me.
    Look here at post 59 and 60
    http://www.greenhulk.net/forums/show...=161992&page=6
    Maybe that's your issue.

  9. #9
    That was it, thanks. Now on to the next issue....

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Driveshaft bearing output seal.
    By nd4spdbh in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-14-2014, 12:11 PM
  2. Help Rex fix his driveshaft/carbon seal thread...
    By RXP-REX in forum 4-Tec Performance
    Replies: 29
    Last Post: 09-11-2013, 11:52 PM
  3. Question about driveshaft bearing seals and water intrusion.
    By RXP-REX in forum 4-Tec Performance
    Replies: 10
    Last Post: 08-14-2009, 08:58 AM
  4. '99 Genesis Driveshaft Seal Leak QUestion
    By 56mulberry in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 06-04-2008, 09:00 PM
  5. Problems with carbon seal leaking-- possibly this instead...
    By VFX_Artist in forum 4-Tec Performance
    Replies: 10
    Last Post: 07-20-2006, 09:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •