Results 1 to 2 of 2
  1. #1

    Sxi Pro ignition problem

    i have an sxi pro with an 800 ccm cylinder and head on it!
    when I finished my project restoring this jet it fires up right away!
    Now after some time I tried to fire it up, it began to run on the highest rpm, this engine can do because of self firing the fuel! After that I recognize that I do only have spark for less than a second! Evertime I start the engine the spark is there for a really short time! What problem can it be, is it possible, that something of the ignition was destroyed, when the engine run too high? Does somebody had problems with the ignition like that?
    thanks for help


  2. #2
    steve45's Avatar
    Join Date
    Feb 2008
    Most likely you have an air leak, which causes the temperatures in the combustion chamber to get hot enough to cause carbon particles to glow and ignite the incoming fuel.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 sxi pro stalling problem???
    By liftedhummersut in forum Kawasaki How To & FAQs
    Replies: 4
    Last Post: 08-31-2009, 05:53 PM
  2. Replies: 3
    Last Post: 08-30-2009, 09:59 PM
  3. pro 785 problems
    By topcat in forum Polaris PWC Performance
    Replies: 16
    Last Post: 08-01-2008, 04:38 AM
  4. I have Ignition Problem With my Sltx Help me!
    By Vortexx972 in forum Polaris Open Discussion
    Replies: 23
    Last Post: 03-03-2008, 02:23 PM
  5. Pro 785 problem.
    By RedlineR6 in forum Polaris How To & FAQs
    Replies: 4
    Last Post: 05-29-2007, 09:19 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts