Page 1 of 2 1 2 LastLast
Results 1 to 10 of 12
  1. #1
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117

    first issue with my RXP

    I just bought a 06 RXP off a fellow GH member. I have put around 2hrs on it so far and I am loving it. however I ran into my first problem today.

    I was out riding the st johns river today (checking out the damage to the mathews bridge from where a cruise ship hit it) in some heavy chop when the oil alarm went off. I went to shore and popped the seat to find the hull full of oil. I called in a favor with a friend and he ran me a gallon of cheap oil so I could get it back to the ramp. it went through about 3 quarts in 3 miles. after lots of cleaning I discovered the PTO driveshaft seal thingy is leaking pretty badly.

    There goes my weekend plans so what causes these things to fail and how hard is it to fix?

    on a side note, while i was cleaning out the hull, I noticed that the drain plugs don't drain. i reach down in the hull and couldn't feel anything blocking them. any ideas?

    thanks


  2. #2
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    If the boot is torn, it can be replaced...but 99% of the time they just get loose.

    There are no drain plugs in the motor, you must suck the oil out through the dipstick....The caps on the bottom just cover the main bolts holding the cases together...

  3. #3
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    Quote Originally Posted by Danny View Post
    If the boot is torn, it can be replaced...but 99% of the time they just get loose.

    There are no drain plugs in the motor, you must suck the oil out through the dipstick....The caps on the bottom just cover the main bolts holding the cases together...
    You saved my weekend Danny. I didn't even think to check the clamps and thats exactly what it was. the rear clamp so loose enough to spin it around. started it up and no leaks. I love easy fixs. thanks a bunch.

  4. #4
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    oh and I meant the hull drain plugs. I had the ski tipped up with a hose in it and they didnt drain. had to use a shop vac

  5. #5
    The drain plugs have a little plastic ball that holds the hole closed if you accidentally leave the plugs undone.
    Sometimes the ball sticks and won't allow anything to flow out of the hull.
    You need to take out the 2 screws holding the plugs and clean them out.

  6. +1 by:


  7. #6
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Mibunkerking ahh another jville bumper rat. You will get all the bugs out in the St. John's river it's nice and calm

  8. #7
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    Quote Originally Posted by shrabber View Post
    Mibunkerking ahh another jville bumper rat. You will get all the bugs out in the St. John's river it's nice and calm
    nice and calm is not how I would've described it. lol figured I check out the landing since I hadn't been there in a while, grab a bite to eat and then try for a gps run in calm water at pottsburg. ended up almost running my motor out of oil and limping home. good thing my friend was in the area cause the few people i know with boats/ski's, their stuff is all broke. I owe him a couple 12packs.

  9. #8
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    I got a GPS maybe pm me the next time you want to test and I will setup a wind tunnel for ya

  10. #9
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    ah your funny. I read you build thread. you got yourself one hell of a machine. would love to see it in action sometime. I'm planning on going out to Huguenot park Saturday after I get off work if you want to meet up.

  11. #10
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Cool let me put her back together, I need to get her out and test

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 8
    Last Post: 09-04-2010, 10:02 PM
  2. More Issues with my 04 RXP
    By 04RXP22 in forum 4-Tec Performance
    Replies: 23
    Last Post: 04-20-2008, 09:13 AM
  3. OMG Problem with my rxp and myself!!!!
    By ADAMBOMB in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 04-20-2006, 09:55 AM
  4. LOL, my dad jumping 6-7 footers with my RXP.
    By theantiRXP in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 08-06-2005, 02:33 AM
  5. Found my Problem with My RXP after Service.
    By Water4fire in forum 4-Tec Performance
    Replies: 5
    Last Post: 06-20-2005, 03:12 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •