Page 1 of 8 1 2 3 ... LastLast
Results 1 to 10 of 74
  1. #1
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117

    so it turns out, TDR waterboxs don't like to overheat...who'da thought

    long story short, I sucked up some sand and it clogged my strainer and the exhaust started to over-heat. alarm went off and I made within 50ft from shore when something went bang. killed it, popped the seat and got steam cleaned. flagged down a guy I just met to tow me in and heard a snap and the ski started sinking. got it to shore before it completely sank but with water over the charger. drained it out and found my TDR WB in 3 pieces.

    got it home and started working on it. I don't think any water made it into the motor as it was shut down way before it sank. pulled the plugs they were dry. no water came out when it turned over. didn't see any in the charger. oil looks ok but hasn't really been churned up much. I'm afraid to start it without a waterbox.

    speaking of which, here's whats left of the WB. I can have the neck welded back on but I don't know about the all the cast pieces. what do you guys think? fixable/replaceable?


  2. #2
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    forgot to add the pics

    Click image for larger version. 

Name:	IMG_1633.jpg 
Views:	165 
Size:	78.0 KB 
ID:	315549Click image for larger version. 

Name:	IMG_1638.jpg 
Views:	203 
Size:	136.6 KB 
ID:	315550Click image for larger version. 

Name:	IMG_1632.jpg 
Views:	172 
Size:	243.6 KB 
ID:	315551Click image for larger version. 

Name:	IMG_1637.jpg 
Views:	167 
Size:	119.2 KB 
ID:	315552Click image for larger version. 

Name:	IMG_1636.jpg 
Views:	158 
Size:	130.6 KB 
ID:	315553

  3. #3
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,069
    +1
    790
    Well with no cooling going thru it, It gets hot as hell. Cant blame the TDR for your lack of checking the groco.
    Im just glad you made it to shore. Also Just for info. I had a head warp when this happened. The exhaust got so hot it transfered wright into the head and warped it slightly. BUT that was enough.

  4. +1 by:


  5. #4
    Boost addict hotbird's Avatar
    Join Date
    Jul 2011
    Location
    Southern WI
    Posts
    5,503
    +1
    681
    are the cast parts from the waterbox or the mid pipe?

    Maybe weld the box back up and fix the mid pipe and go?

  6. #5
    Water4fire's Avatar
    Join Date
    May 2005
    Location
    New Braunfels TX.
    Posts
    10,069
    +1
    790
    Quote Originally Posted by hotbird View Post
    are the cast parts from the waterbox or the mid pipe?

    Maybe weld the box back up and fix the mid pipe and go?
    From the mid pipe.

  7. +1 by:


  8. #6
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    That's why I run a separate line to the exhaust and only run strainer before my ic and heat exchanger.

    I don't think you can fault the tdr box as the mid pipe looks just as bad.

  9. +1 by:


  10. #7
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Austin
    Was that with closed loop or open loop?
    Another reason I prefer closed system with coolant.
    Quote Originally Posted by Water4fire View Post
    Well with no cooling going thru it, It gets hot as hell. Cant blame the TDR for your lack of checking the groco.
    Im just glad you made it to shore. Also Just for info. I had a head warp when this happened. The exhaust got so hot it transfered wright into the head and warped it slightly. BUT that was enough.

  11. #8
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    I was being sarcastic. it is completely my fault and now I get fix my mistakes.

  12. #9
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    I am running closed loop. just the exhaust over heated.

    can I get a mid pipe seperately?

  13. #10
    West Texas RXP skoepp's Avatar
    Join Date
    Oct 2007
    Location
    west texas
    Posts
    12,019
    +1
    149
    Run a separate line to the exhaust without the strainer in line.

Page 1 of 8 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXP its coming out of fuel when turning????
    By maestro in forum 4-Tec Performance
    Replies: 14
    Last Post: 07-13-2011, 01:34 PM
  2. should i wait till its warm out???
    By xplayer2885 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 03-31-2007, 12:13 PM
  3. so its true, isnt it NATE...........
    By WATER WOODY in forum Open Discussion
    Replies: 2
    Last Post: 09-06-2006, 07:04 PM
  4. TDR Waterbox?
    By Yellow93 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 05-14-2006, 11:34 AM
  5. So its 55º here
    By Pettee in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 12-27-2005, 08:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •