Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1

    300x low RPMs and low mph, problem solved !!!

    I love our 2011 Kawi 300x. The best ski we have ever owned. The only mods are an aftermarket steering system from Idiartec and a R&D SCOM.

    I was hoping to get a few extra mph with the R&D SCOM, but the best I would get was a little over 68 mph. I read several postings (on greenhulk) how my rpms should be in the 7800's, but I was at 7610 rpm. I knew there was a problem, but didn't know what.

    The guys at R&D tested my intercooler valve and it wouldn't hold any pressure (it was leaking). They popped on a new trick valve and it solve my problem. Now I'm at 70.9 mph (I'm heavy) and 7840 rpm. These valves are now available, contact R&D in Santa Fe Springs or your local R&D distributor.


    Click image for larger version. 

Name:	1381596_725348007479306_1228965750_n.jpg 
Views:	91 
Size:	157.6 KB 
ID:	315695
    stock valve with SCOM

    Click image for larger version. 

Name:	72641_725348090812631_718404791_n.jpg 
Views:	117 
Size:	123.2 KB 
ID:	315696
    R&D valve results with SCOM


  2. #2
    Spooling's Avatar
    Join Date
    Sep 2011
    Location
    West Coast of Florida
    Posts
    1,285
    +1
    177
    Good Job - Glad R&D helped you get things sorted out !!!

    PS - "stored" RPM is always different and a numerical value that is < a "live" RPM reading.

  3. #3
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    very correct ed ^ never take notice of stored rpm as its actually backward recorded, meaning if the speed is maxed out before max rpms are reached this is all that is recorded. wonder if the op actually did have a faulty bypass or bov in the first place. they arent something that ever give any trouble. my guess is coincidentally he has ridden again and got a differing max rpm reading..

  4. +1 by:


  5. #4
    So I installed a new R&D Adjustable Boost Control Valve. I picked up 230 rpm a couple mph top speed. If your down on power like I was, send your OEM valve to R&D to pressure test it. It's a 25.00 service (if leaking) that will apply towards the purchase of their new valve.

  6. #5
    Sorry guys, I'm pretty jazzed about this and using a phone to do my postings. Thanks for the input.

  7. #6
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    so exactly which valve are you talking about? as the oem valve is already adjustable they way i see it they saw you coming lol

  8. #7
    Banned User
    Join Date
    Jul 2013
    Posts
    424
    +1
    40
    Most just block that valve off, with a stock prop you should be seeing about 8000 rpm. That Idiartec steering is trick, how about a few pics of it?

  9. #8
    Is this the product? - R&D also told me the valve attached to the back if the intercoolers fails all of the time - I went from never getting over 7300 rpm to now around 7500 rpm (had a timing issue)- I am still I am not getting the rpm's I should around 7800+

    Click image for larger version. 

Name:	image.jpg 
Views:	85 
Size:	24.0 KB 
ID:	315806

  10. #9
    Spooling's Avatar
    Join Date
    Sep 2011
    Location
    West Coast of Florida
    Posts
    1,285
    +1
    177
    Quote Originally Posted by nicjak View Post
    stored rpm as its actually backward recorded, meaning if the speed is maxed out before max rpms are reached this is all that is recorded.
    -------------------

    Interesting, I always wondered why...

  11. #10
    nicjak's Avatar
    Join Date
    Mar 2008
    Location
    Warragul, Downunder
    Posts
    7,794
    +1
    625
    that is just a tool, a bov testor. the oem valve does not fail, once rpms are increased it bleads off the extra boost to gain more boost we adjust the spring pressure on the oem valve or we just remove it.

    Quote Originally Posted by John Arnaut View Post
    Is this the product? - R&D also told me the valve attached to the back if the intercoolers fails all of the time - I went from never getting over 7300 rpm to now around 7500 rpm (had a timing issue)- I am still I am not getting the rpm's I should around 7800+

    Click image for larger version. 

Name:	image.jpg 
Views:	85 
Size:	24.0 KB 
ID:	315806

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 300 more RPM and 0 MPH
    By eb87 in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-10-2016, 06:17 PM
  2. Replies: 6
    Last Post: 08-23-2014, 10:04 PM
  3. RXT only turning 7600 RPM and 54 MPH GPS??
    By richte18 in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 06-29-2014, 10:08 PM
  4. 1200 xlt running max 5700 rpms and 40 mph
    By BluYama1200 in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 08-15-2013, 05:13 AM
  5. 600 RPM and 5 mph Loss?
    By Red Devil in forum 4-Tec Performance
    Replies: 30
    Last Post: 07-28-2005, 09:53 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •