Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1

    Running Rich update

    Well I purchased the inovate MTX-L AFR to see if it was running lean.Took it out and it was idling at 11:1, did a wot run and it leveled ot at 14.7:1 . A little lean ,let off on the throttle and the gauge gave me an E8 code ( damaged sensor ). I took the sensor out and it was wet. I called tech support and he told me that idling so rich wiped the sensor out or it got wet.
    I have the bung welded at the top of the j pipe about 1 inch ahead of the water fitting. When I welded it I drilled an 1 1/4 hole in the outside jacket and a 1" hole in the inner pipe. Welded the bung into the inner pipe first then welded the outer jacket to the bung. My question is ,I thought the inside of the pipe was dry at that point , the tech said 1 drop of water on a hot sensor and it is done , it will crack the ceramic.He was nice enough to give me the bosch part # 17014-$60.00
    at discount auto. Have I done somthing wrong ?


  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    you said wet....water or gas
    if is water wet there is a leak
    wot aft 14 is not a little lean its melt down lean

  3. #3
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    Get the o2 in your Manifold. Do You Own a RRFPR?

  4. #4
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    Not sure how you managed 14.7 WOT without severe knock and the ECU pulling all your timing out.

  5. #5
    spouk3's Avatar
    Join Date
    Mar 2012
    Location
    Montreal, QC, Canada
    Posts
    635
    +1
    30
    A quick question... How can an O2 sensor can get wet inside an exhaust manifold? Water can get there? I don't understand...

  6. #6
    formerly Gold06RXP Turbo Nick's Avatar
    Join Date
    May 2007
    Location
    Dayton, OH
    Posts
    2,095
    +1
    97
    Quote Originally Posted by spouk3 View Post
    A quick question... How can an O2 sensor can get wet inside an exhaust manifold? Water can get there? I don't understand...
    Bad weld!! Leaking

  7. #7
    shrabber's Avatar
    Join Date
    Apr 2008
    Location
    Jacksonville, FL
    Posts
    5,305
    +1
    376
    A few ways Internal water leak,cracked head,Blown head gasket,cracked exhaust manifold.

  8. #8
    spouk3's Avatar
    Join Date
    Mar 2012
    Location
    Montreal, QC, Canada
    Posts
    635
    +1
    30
    Ha! OK... I drilled my manifold with the RIVA kit... Thanks for the info

  9. #9
    Quote Originally Posted by skidoochris View Post
    you said wet....water or gas
    if is water wet there is a leak
    wot aft 14 is not a little lean its melt down lean

    It was water. Yes I agree that is lean , my previous post " Running lean " from last week I was tring to adjust AFR with a narrow band.

  10. #10
    Is it safe to tap 18 mm next to water fitting? Yas I am using a 1:1 regulator

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 slt 750 runs rich, boggs
    By brianstrange in forum Polaris Open Discussion
    Replies: 6
    Last Post: 07-10-2008, 10:04 AM
  2. 05 scic running rich
    By Giligan in forum Sea Doo Sport Boats
    Replies: 4
    Last Post: 07-01-2008, 09:53 PM
  3. Polaris SL650 Fuel Mixture (running Rich)
    By danwann in forum Polaris Open Discussion
    Replies: 9
    Last Post: 06-16-2008, 06:50 PM
  4. Polaris SL650 Fuel Mixture (running Rich)
    By danwann in forum Yamaha How To & FAQs
    Replies: 0
    Last Post: 06-02-2008, 08:52 AM
  5. running rich?
    By shhr in forum 4-Tec Performance
    Replies: 10
    Last Post: 06-02-2007, 10:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •