Results 1 to 4 of 4
  1. #1

    2001 Polaris Virage,701,3 seater,red engine.Engine revs up but won't move forward.

    I know this has already been discussed but I could not find a previous post.When I crank the ski in forward,the engine revs up but does not move forward.Something slipping?Is there a key that maybe I broke?Any and all help would be appreciated.I was taking the ski out of the lake to take on Vacation in the morning when this happens,so I am hoping it is a quick and simple fix.Thanks in advance.Bill


  2. #2
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Welcome

    Remove the jet pump and inspect the drive splines at both ends of the drive shaft, and the mating engine coupler and impeller. Do not lose the little rubber bumpers on the ends.

    Also check the rubber bonded coupler for signs of slippage.

    See my signature links for details on removing the jet pump and the rubber bonded coupler.
    Last edited by K447; 10-08-2013 at 07:04 PM.

  3. #3
    K447,Thank you so much for the help.I removed the Jet Pump.Splined ends look great,The rubber bonded coupler is torn.I can not find it as a separate part?The impellar was locked up with a piece of wood.Thanks again for the help.

  4. #4
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Quote Originally Posted by felderlostnspace
    Quote Originally Posted by K447
    The rubber bonded coupler is the big round drive shaft coupler attached to the rear of the engine.

    If the engine was turning and the impeller was jammed and not turning, then something in the driveline has striped or failed. The engine is directly coupled to the impeller, one cannot turn without the other unless something is broken.

    There is a round seal where the driveshaft goes into the impeller. It should be replaced if it is damaged.
    Quote Originally Posted by felderlostnspace
    Quote Originally Posted by K447
    Quote Originally Posted by felderlostnspace
    I really appreciate your response to my post,2001 Polaris Virage drive shaft or impeller slipping.How do I get to your instructions on removing the jet pump.Sorry,I am new to this.Thanks again for the help.Bill
    Just follow the links from my signature, which should appear right below my posts...
    Thank you so much for the help.I removed the jet pump and checked the splines.They looked great.The only damage I saw was a stick caught in between the impellar and the housing causing the impellar not to turn.The round rubber bonded coupler is torn.I guess that what you are talking about,It is on the end of the shaft that goes into the impellar.Thanks again for any help.Bill
    Ok,Thankls again for the help.I found the coupler that is at the rear of the engine and will try to remove it.Dont know if I will have it ready by tomorrow noon to leave on vacation,but I am going to try ...
    You do not need to remove the engine coupler to inspect it. A small mirror and light will often be enough. Do not stick your finger into the coupler, metal splinters are painful.

    To remove the coupler, search for my notes on the 'rope trick' which is needed to hold the crank shaft in place while you use a really big wrench to loosen the coupler from the engine.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2001 Polaris Virage TXi Check engine, RPM limit 3500
    By ValBugi in forum Polaris Open Discussion
    Replies: 27
    Last Post: 06-10-2013, 09:02 PM
  2. 2001 Polaris Virage 701 no spark
    By hoogie in forum Polaris Tech Tips and Info
    Replies: 0
    Last Post: 06-26-2012, 10:41 PM
  3. 2001 Polaris Virage TX Problems after engine was rebuilt
    By boosti04 in forum Polaris Open Discussion
    Replies: 12
    Last Post: 06-24-2011, 01:53 PM
  4. FS 2001 polaris virage txi engine harness
    By 2&4strokepolaristech in forum Polaris Classifieds
    Replies: 1
    Last Post: 10-04-2009, 12:47 AM
  5. 2001 polaris virage want to rebuild engine
    By h23pasadena23 in forum Polaris Open Discussion
    Replies: 5
    Last Post: 04-03-2009, 02:51 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •