Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 29
  1. #1
    TheEngineer's Avatar
    Join Date
    Aug 2007
    Location
    Tampa, FL
    Posts
    934
    +1
    131

    RXP-X 260 slow at 8480 RPM

    My RXP-X is currently running 8480 at WOT but its speed is topping out at about 69.5-70.5. I believe it should be a few mph faster at that RPM. Any ideas on what to check first?


  2. #2
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    impeller/wear ring then carbon seal. Look for cavitation issues.

    Stop towing fat people.

  3. #3
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Santa Hat???

  4. #4
    TheEngineer's Avatar
    Join Date
    Aug 2007
    Location
    Tampa, FL
    Posts
    934
    +1
    131
    Prop and wear ring are brand new, along with the carbon seal and hat. No cavitation at all. Accelerates smooth.

  5. #5
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    The water is thicker in Tampa..

    Your right turning those rpm I would think your missing 2+ mph.

    What's your secret intake grate??

    If its not the grate then the usual suspects... Impeller , wear ring... Cavitation....

  6. #6
    Live Fast wave15stx's Avatar
    Join Date
    May 2007
    Location
    new jersey
    Posts
    2,214
    +1
    32
    What does it usually run?

  7. #7
    Mod less, ride more! troyheb's Avatar
    Join Date
    Jul 2007
    Location
    Nederland, Texas
    Posts
    8,725
    +1
    1,267
    What trim position?
    Check your ride plate angle. To get these skis to run you need to get them out of the water.

  8. #8
    dnielsen's Avatar
    Join Date
    May 2008
    Location
    Shreveport, Louisiana
    Posts
    2,018
    +1
    94
    A V-Tech tune and no power adders or adjustments to rideplate and speeds look about right to me. Tweaking the prop and raising the RPMs will only get you a small increase in speed. Add some boost, air, and exaust and let her rip!

  9. #9
    TheEngineer's Avatar
    Join Date
    Aug 2007
    Location
    Tampa, FL
    Posts
    934
    +1
    131
    Quote Originally Posted by dnielsen View Post
    A V-Tech tune and no power adders or adjustments to rideplate and speeds look about right to me. Tweaking the prop and raising the RPMs will only get you a small increase in speed. Add some boost, air, and exaust and let her rip!
    There are a lot of guys running a nearly identical setup and seeing way faster than I've seen. At minimum I would think I'd be running 72 right now.

  10. #10
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Salt water is more dense and speeds are reduced a little over fresh water..

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Stock 260 impeller at higher RPMs?
    By ptscon in forum 4-Tec Performance
    Replies: 7
    Last Post: 06-28-2016, 08:42 PM
  2. 2015 RXP-X 260 Not getting full RPM?
    By Lstorm2003 in forum 4-Tec Performance
    Replies: 14
    Last Post: 05-31-2016, 06:42 PM
  3. RXP-X 260 slow crank issues
    By RXPX12 in forum 4-Tec Performance
    Replies: 0
    Last Post: 05-27-2014, 02:33 PM
  4. Slow accel RXP - maxing at 6000 rpms
    By wolf513 in forum 4-Tec Performance
    Replies: 11
    Last Post: 07-07-2008, 08:58 PM
  5. My stage 2 RXP, 75.5+mph at 7900 rpms, yahoo!
    By Vern in forum 4-Tec Performance
    Replies: 23
    Last Post: 06-21-2006, 11:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •