Results 1 to 5 of 5
  1. #1

    2004 RXP Loss of Power, Suspecting Supercharger

    Hi All,


    This is not my first rodeo with a broken supercharger, but this time I am having trouble identifying the problem. Please bear with my long winded explaination, this problem got pretty complicated.

    Background on Ski: 2004 RXP, Riva Stage 1 Kit. 185 hours on it. I bought at 105 hours and shortly after had the worst happen, ceramic washers were still installed (despite what the previous owner said.) They exploded and went through the engine. Had Jerry rebuild Charger, and local shop tore engine apart, deftermined only the oil pumps were damaged and rebuilt it. Safe, or at least for the moment. 80 hours of flawless operation after that other than regular maintainance until now.

    The current situation: Put the ski in the water one day, start to hit the gas after leaving the marina. Bam, all of the sudden felt a big loss of power and vibration. Quickly turned it off. Thought I sucked something up in the impeller. Pulled it out, removed the pump and found nothing. Put the pump back in, placed the ski in the water, same problem. But then to my horror it starts sinking, so my strongest friends and I ram it onto the beach while we race to get the trailer down. Got it on the trailer without the water going much higher than the SC. Took it to the shop, told them about both of the problems. They fear the worst and check to make sure water didn't get in the oil. Thankfully, I did not turn it on while it was sinking so there was no sign of water in the oil (or hydro lock). They replace the seals no problem. Sinking problem fixed.

    Onto the power problem. The mechanic noticed the oil was really low (a quart to be exact) and fills it. They then run it (out of water) to try and find the power problem, and determine that it is fine. I figured they fixed it and was happy.

    I take it to the lake, put it in the water, and things sound fine at idle while in the no wake zone. I can hear the charger whining and there is no vibration. But, as I leave the no wake and hit the gas, the same happens again as before. After I get it to 5000 rpms at normal acceleration, it has the drastic drop in power and goes back to acting strange.

    The problem: At idle out of water, everything is fine. In the water though, it is another story. At idle I can hear the supercharger whirring at times but the sound goes in and out, along with the power of the idle. When the power diminishes and I cannot hear the supercharger, there is a rather intense vibration. If i gas it, the supercharger is completely dead and the vibration is even more intense. It almost feels like I have lost a cylinder. I tested the SC and it is tight to the fingers. I also pulled it to check for wear, damage, and torque levels. All are normal. There is an unusual amount of oil present in the hull though (possible related?)

    The solution?: Could the SC be that worn and slipping? Any other easy explainations that I missed?


    Thanks in advance guys.


  2. #2
    Banned User
    Join Date
    Dec 2006
    Location
    Crest Hill, IL
    Posts
    9,512
    +1
    215
    Vibration comes form something spinning, throwing off the balance...

    Pull the pump, check it...

    Check to see if the wear ring is spinning in the pump......I got a buddy's ski here that has the same pump as you, pulled it off, and the ring is spinning...It should be a tight fit...

  3. #3
    warsawspeedfreak's Avatar
    Join Date
    Jan 2010
    Location
    Tinley Park, IL
    Posts
    369
    +1
    19
    I personally would start with a spark plug change first. Read the plugs...all same color, not one different. 185 hours...possibly a weak or bad fuel injector. That would explain the rough idle, whine going in and out if the idle is dropping and crappy power up top. You said a shop looked a the motor before so you can only assume that all is good based on their word. There is a way to test your injectors probably or I'm pretty sure you could find a new set of 38lbs injector cheap. Plenty of people have them...Thats where I would start...

  4. #4
    warsawspeedfreak's Avatar
    Join Date
    Jan 2010
    Location
    Tinley Park, IL
    Posts
    369
    +1
    19
    Also If you have the ability a compression test will give a good basic idea about the health of you engine...

  5. #5
    Sit down, Shut up, and hang on!!! Karl Jackson's Avatar
    Join Date
    Nov 2010
    Location
    Timaru New Zealand
    Posts
    60
    +1
    1
    Quote Originally Posted by warsawspeedfreak View Post
    Also If you have the ability a compression test will give a good basic idea about the health of you engine...
    + 1 on the compression test...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Instant Loss of Power 2006 RXP with Riva SC Washers
    By synergy141 in forum 4-Tec Performance
    Replies: 52
    Last Post: 07-15-2016, 04:16 PM
  2. HELP! 06 RXP loss of power!
    By IanuR1 in forum 4-Tec Performance
    Replies: 25
    Last Post: 09-09-2013, 06:20 PM
  3. help 05 rxp loss of power
    By MuffSquad in forum Sea Doo Open Discussion
    Replies: 9
    Last Post: 06-08-2009, 11:18 PM
  4. Replies: 6
    Last Post: 07-06-2008, 09:48 PM
  5. Loss of power 04 RXP
    By PossisRXP in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 05-14-2006, 06:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •