Results 1 to 2 of 2
  1. #1

    GP 800 lost power

    I was riding my ski today and heard a pop sound. I soon lost rpm's. It was still running but only going about 8 mph. The engine compartment had oily residue and the underneath of my seat had black oily splatters. Any ideas?? I have had problems with this ski in the past as others have with the heat transfer to carb issues. Today was different.


  2. #2
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    Compression test it.
    Splatter under the seat could be a loose spark plug.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts Wanted - Power Valves for 98 GP 800
    By chicagoanalog in forum Yamaha Classifieds
    Replies: 1
    Last Post: 07-05-2012, 08:55 PM
  2. 2000 GP 800 Power Valves?
    By seasure1 in forum Yamaha PWC Performance (2-stroke)
    Replies: 4
    Last Post: 10-04-2007, 07:57 PM
  3. Lost power
    By John in forum 4-Tec Performance
    Replies: 19
    Last Post: 08-08-2006, 03:15 PM
  4. 1999 gp 800
    By Island racer in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 05-27-2006, 01:30 PM
  5. 05 rxp lost power
    By 1969camaro-rs in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-10-2005, 08:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •