Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17

Thread: Canon FTW!!!

  1. #1
    DrivingZiggy's Avatar
    Join Date
    May 2013
    Location
    Lafayette, LA
    Posts
    1,938
    +1
    349

    Canon FTW!!!

    I rurnt (okay, ruint)(okay, ruined) my Canon HF M30 on the Bahamas trip by getting it splashed by the salt water too many times. But I wanted to recover my pics and vids!


    So I went to the camera repair place, he said no way. I took it to the computer repair guy, he said maybe if you have an identical camera and switch out the board. He wasn't able to recover anything from the internal memory.


    So I called Canon. The regular tech guys couldn't help, but he gave me the address in Virginia to send it with a detailed note about what happened and what I wanted. So I did that.


    Then I got an e-mail from them saying to give them $185 to repair the camera. I was wishy-washy about that because what I really wanted was the memory. So I called their number and the chick said give me money and I'll send them a note. So I authorized the $185.


    The box arrived today. And as I'm pulling the stuff out, I'm all WTF??? because it's obviously not a complete camera but pieces! So I look at the invoice and it says they weren't able to fix it because of the corrosion and tampering.


    But there's an SD card in there--they were able to pull the pics/vids! And the invoice is also all zeroes. So I checked my credit card statement and sho 'nuff they had reversed the $185 back onto my card. And I didn't even ask them to because I would have paid that just for the pics anyway.


    The wife and I agree that when business pics up and we're ready for another nice camera, Canon will indeed get our money again!

    Oh, and I'm now waiting on the GoPro footage from one of the other guys who went, then I'll mash together a vid and post up.


  2. #2
    83Gator's Avatar
    Join Date
    Jul 2008
    Location
    St. Amant, LA
    Posts
    6,018
    +1
    304
    Well, congrats on salvaging the pix. That's the important thing. I, too, was recently considering Cannon: My Panny took a dive in L. Maurepas about 2 months ago. I gave it a "rice" sauna overnight. Removed it from the bag of rice the next AM and still shook water out of all the ports. WTH and nothing to lose, I left the camera in direct sunlight all that next day. Over the next 2 to 3 days, it would power up and then shut off... I figured it a lost cause and left it alone for a few more days. By the end of the week it powered up w/most of the options working, but not all. Well, 2 months later, the damn thing is up and running; the molding on the housing is coming apart but it still taking great pix. This Panny has now dropped/slid down a 100 foot cliff, been left in a cave, covered in mud, and now been dunked under water. Uhm... I think my next camera will be a Panasonic, again...

  3. #3
    Moderator beerdart's Avatar
    Join Date
    Aug 2006
    Location
    CT
    Posts
    25,929
    +1
    1,407
    Thats great customer service.

  4. +1 by:


  5. #4
    DrivingZiggy's Avatar
    Join Date
    May 2013
    Location
    Lafayette, LA
    Posts
    1,938
    +1
    349
    Quote Originally Posted by 83Gator View Post
    Well, congrats on salvaging the pix. That's the important thing. I, too, was recently considering Cannon: My Panny took a dive in L. Maurepas about 2 months ago. I gave it a "rice" sauna overnight. Removed it from the bag of rice the next AM and still shook water out of all the ports. WTH and nothing to lose, I left the camera in direct sunlight all that next day. Over the next 2 to 3 days, it would power up and then shut off... I figured it a lost cause and left it alone for a few more days. By the end of the week it powered up w/most of the options working, but not all. Well, 2 months later, the damn thing is up and running; the molding on the housing is coming apart but it still taking great pix. This Panny has now dropped/slid down a 100 foot cliff, been left in a cave, covered in mud, and now been dunked under water. Uhm... I think my next camera will be a Panasonic, again...
    Yeah, Grace was commenting on how good your picture quality is ever since MudBug. It takes a lot to impress her! We read a bunch of Amazon reviews before deciding on the Canon. The only Panasonic I ever had was a really cheap one that looked similar to my Canon, but the first time I brought it to the drag strip I found that it had a hard time focusing on cars going down the track. So I sold it on eBay. Obviously it wasn't nearly as good as yours.

    Quote Originally Posted by beerdart View Post
    Thats great customer service.
    I agree! I love it when somebody actually shows me that the want to keep my business. Especially if their product is good!

    I guess I'll give you guys a little teaser of the quality of the Canon. Here ya go.

    Attachment 316381Attachment 316382Attachment 316383

    Seems like my vids are too long, so you're all gonna hafta wait for me to make my movie.

  6. #5
    DrivingZiggy's Avatar
    Join Date
    May 2013
    Location
    Lafayette, LA
    Posts
    1,938
    +1
    349
    Anybody know why my pics aren't loading right? I clicking on the pic icon and uploading, but then they don't show...

  7. #6
    83Gator's Avatar
    Join Date
    Jul 2008
    Location
    St. Amant, LA
    Posts
    6,018
    +1
    304
    Thanks, Brian (and "hi" to Grace). That camera has taking a licking and keeps churning out some pix. BTW, if you saw my last post in LA Conn, I was kinda hoping I might see you guys out on the water. Also, IDK what's going on, but I couldn't upload any pix on the site for 3 days but all seems good now.

  8. #7
    Click avatar for tech links/info, donation request K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    36,587
    +1
    1,272
    Quote Originally Posted by DrivingZiggy View Post
    Anybody know why my pics aren't loading right? I clicking on the pic icon and uploading, but then they don't show...
    There has been some server maintenance work happening 'in the background'.

    Try using the Advanced Mode to reply, then scrolling down to Manage Attachments.

    If that also does not work, send a Private Message to Mike Trin. Give him the details of what is not working, including Windows version, browser name and version, etc.

  9. #8

    Join Date
    Sep 2010
    Location
    Aliso Viejo
    Posts
    951
    +1
    75
    Canon has a repair center in Irvine, California. Very close to where I live. I've used them many times. Stand up guys!
    You want s hity customer service...contact GoPro...I will not buy their products anymore.

  10. #9
    Sea-Donkey's Avatar
    Join Date
    Apr 2012
    Location
    Mississippi
    Posts
    892
    +1
    107
    Where's the pics? I paid my membership dues!

  11. +1 by:


  12. #10
    DrivingZiggy's Avatar
    Join Date
    May 2013
    Location
    Lafayette, LA
    Posts
    1,938
    +1
    349
    I'm gonna put together a "movie" as soon as I receive the other guy's GoPro footage. But here's a couple:

    Attachment 316837Attachment 316838Attachment 316839Attachment 316840

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 11
    Last Post: 06-12-2014, 11:51 AM
  2. Replies: 8
    Last Post: 08-16-2011, 08:51 AM
  3. FS Sigma 18-200 lens Canon mount
    By mrbtd in forum General Classifieds
    Replies: 3
    Last Post: 01-13-2010, 07:10 AM
  4. Replies: 3
    Last Post: 07-13-2009, 04:47 PM
  5. Does anyone know where to buy canon cheap?
    By boataddict in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 07-17-2006, 09:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •