Results 1 to 5 of 5
  1. #1
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246

    Swapping valve spring question help needed

    Okay, so I have the Riva valve tool installed as per their instructions, I have the cylinder pressurized to about 80-90 psi steady. See pics

    heres the silly question,

    why when I begin to compress the valve spring the entire valve opens?

    The tool appears to be square with the retainer but as soon as I compress, you can see the entire valve, retainer and keepers opening and you can hear the air escape from either the exhaust or intake.

    Ive tried all four valves on the cylinder. It's a pretty straight forward affair.

    Wtf am am I doing wrong?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	52 
Size:	97.4 KB 
ID:	316713   Click image for larger version. 

Name:	image.jpg 
Views:	42 
Size:	89.5 KB 
ID:	316714  


  2. #2
    Sayers's Avatar
    Join Date
    Jul 2010
    Location
    Melbourne AUS
    Posts
    2,300
    +1
    134
    Sometimes they stick a bit. Give them a light tap with a rubber mallet prior.

  3. +1 by:


  4. #3
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246
    Quote Originally Posted by Sayers View Post
    Sometimes they stick a bit. Give them a light tap with a rubber mallet prior.
    Thank you! I'm going to try that In a few

  5. #4
    Preload the retainer with the compressor to right before the air leaks. Then smack/tap the retainer with a brass punch.

  6. #5
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246
    Quote Originally Posted by Sayers View Post
    Sometimes they stick a bit. Give them a light tap with a rubber mallet prior.
    SUCCESS ! Gave a light tap to the valve stem with a brass drift then proceeded to compress the spring and voilà !

    The retainers separated from the keepers and got all four swapped out. You think Riva would have put that little note in their instructions.

    THANK YOU SO MUCH GUYS!!!!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	image.jpg 
Views:	56 
Size:	41.7 KB 
ID:	316718  

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2007 RXT Valves & Valve Springs Question
    By loganjj27 in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-30-2015, 12:57 PM
  2. Valve spring question - Color codes on OEM springs?
    By boostaholic in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-31-2014, 12:01 PM
  3. FZS Blow off Valve install question-Need help
    By smitch in forum Yamaha PWC Performance (4-stroke)
    Replies: 9
    Last Post: 08-03-2010, 10:14 PM
  4. gas valve springs please help
    By joeblo in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 12-09-2006, 02:32 AM
  5. pro 785 questions \ help needed
    By [email protected] in forum Polaris PWC Performance
    Replies: 14
    Last Post: 09-13-2006, 08:40 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •