Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 39
  1. #1

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    3,443
    +1
    653

    2012 RXPX60 How much boost should I be getting out of my XXX Charger

    So here are some stats from two days runs...from my motec log.

    Water temp both days 77 degrees (salt water)

    Saturday: Air Temp 86F
    ------
    RPM; 8700
    Intake Pressure; 14.2psi
    Intake Temp; 91.1 F
    lambda: .815
    timing: 33.1 S
    SeaDoo GPS: 76.9mph


    Sunday; Air temp 71F
    ------
    RPM; 8800
    Intake Pressure; 15.1psi
    Itake Tempature; 92F
    lambda: .792
    timing: 33degrees
    SeaDoo GPS: 80.3mph

    I'm running all the parts specified in the Riva Stage 4 kit...except now I'm running a Motec

    A few notes... the 80.3mph was a nice long run, the 76.9mph was pretty short. Also the Speedo showed 82 the whole time while the motec read 80.3 from the can bus that feeds the speedo/dash. I find that real interesting...since we all know the stock dash is off 2 mph roughly. It seems like they could make it real accurate if they wanted to as the data is there.

    Another note, I shimmed the trailing edge my stock trim tabs with a piece of motor shim. I was getting a little bounce around 78mph...now it's solid at least up to 80.

    So the XXX charger spec says I should be getting 14psi @ 8,100rmp and 15.5psi @ 8500. What gives? Did I get tricked by the marketing again? Is that Pre IC #'s on a 30degree day on a full moon?

    Another interesting fact. Both the Athena computer and Motec ran the same boost/lambda/speed #'s at WOT. Only difference is the Motec is spot on across the rest of the map where the Athena was running super rich across 7k-8.6k. I suppose if I took the time I could have tuned it out...but I was lazy and got the Motec. My ride time has literally doubled now that the map is seemingly spot on.

    Thoughts?
    Last edited by DinoMite; 10-21-2013 at 10:17 PM.


  2. #2
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    well do you have the sensor before or after the IC
    also when was the last time the slip was checked
    it seems the sc builders hope you don't log so they can run them a little loose
    and have less of a chance of a touchdown

  3. #3

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    3,443
    +1
    653
    Quote Originally Posted by skidoochris View Post
    well do you have the sensor before or after the IC
    also when was the last time the slip was checked
    it seems the sc builders hope you don't log so they can run them a little loose
    and have less of a chance of a touchdown
    All the sensors are stock/stock location. It seems like we checked it when I took the stock SC off. I don't remember what the reading was, the guy helping me was X sea tech with allot of mod experience. I'm thinking he would've said something. I will need to recheck it. One thing I can say is, it has been putting out the same boost since I put it on probably 15ish hours now?

    Should it really be putting out 15.5lbs of boost at 8500? If so that would be a huge difference in what it's doing now
    11.5ish at 8100, 13.6ish at 8500rpm.

  4. #4
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246
    Quote Originally Posted by DinoMite View Post
    Quote Originally Posted by skidoochris View Post
    well do you have the sensor before or after the IC
    also when was the last time the slip was checked
    it seems the sc builders hope you don't log so they can run them a little loose
    and have less of a chance of a touchdown
    All the sensors are stock/stock location. It seems like we checked it when I took the stock SC off. I don't remember what the reading was, the guy helping me was X sea tech with allot of mod experience. I'm thinking he would've said something. I will need to recheck it. One thing I can say is, it has been putting out the same boost since I put it on probably 15ish hours now?

    Should it really be putting out 15.5lbs of boost at 8500? If so that would be a huge difference in what it's doing now
    11.5ish at 8100, 13.6ish at 8500rpm.
    You had that much of a temp drop from sat to Sunday? It was 90* here today. I wish it was 71

  5. #5

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    3,443
    +1
    653
    yah, it was later in the day mid 80's on Saturday when I went out around 4 and on Sunday it was about 70f at 10am when I went out. High on Sunday was a chilly 77...BURRR almost put my jacket on. Basically 15degree temp between the two runs

  6. #6
    dpracing's Avatar
    Join Date
    Jan 2008
    Location
    Palm Beach, Florida
    Posts
    1,244
    +1
    246
    Quote Originally Posted by DinoMite View Post
    yah, it was later in the day mid 80's on Saturday when I went out around 4 and on Sunday it was about 70f at 10am when I went out. High on Sunday was a chilly 77...BURRR almost put my jacket on. Basically 15degree temp between the two runs
    That a big diff in temp. But a good one.

  7. #7
    Nothin' better than Doo'in it! BigDaddyRXP's Avatar
    Join Date
    Aug 2007
    Location
    Tampa Bay, FL
    Posts
    9,202
    +1
    673
    Quote Originally Posted by DinoMite View Post
    What gives? Did I get tricked by the marketing again?
    No way! Riva's NEVER done that before

    There's only one real brand of charger out there worth having..... and it doesn't have "Riva" laser engraved on it. And even if it does.... it's not developed, or made by them anyway

  8. #8
    Boost is very much tied to RPM. HP is very much tied to boost and RPM. RPM is very lake temp and air temp sensitive. Engine life expectations goes down with all this stuff.

    Bottom line is this stuff is all tied together in ways that make giving straight answers very difficult to impossible.

    Andy

  9. #9
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,037
    +1
    672
    so no 16-18psi as some claim. Weird. They also need more maintenance than ET. Hmmmm.

    Sorry buddy but there's a reason why you see ET in signatures. Riva is like Bose now. All hype (IMHFO)


  10. #10
    wotxxxsd's Avatar
    Join Date
    May 2012
    Location
    Orlando
    Posts
    3,928
    +1
    472
    In other words the stars have to line up perfectly to get the optimum results...

Page 1 of 4 1 2 3 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. how much grease should i put in cone of svho?
    By macattack in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-24-2016, 04:46 AM
  2. Replies: 6
    Last Post: 09-21-2013, 04:10 PM
  3. 96 gti, how much oil should it be using? can you pre mix?
    By rocksandblues in forum 2-Stroke Performance
    Replies: 2
    Last Post: 07-10-2013, 07:35 AM
  4. Replies: 2
    Last Post: 08-25-2011, 10:33 PM
  5. 95 XP. Should oil be squirting out of the pulse line?
    By oneeyedjack in forum 2-Stroke Performance
    Replies: 7
    Last Post: 04-14-2008, 04:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •