Results 1 to 6 of 6
  1. #1
    alex29573's Avatar
    Join Date
    Mar 2008
    Location
    miami
    Posts
    658
    +1
    1

    Intermittent 12V LOW

    My ski has been flashing 12V LOW intermittently for about 2 weeks now.

    I have charged my battery at the auto parts store and still the same thing.
    I also installed my friend's battery and it still does it...

    Its more annoying than anything b/c it doesnt affect performance. It still starts right up its just that it flashes the warning sometimes.

    What is causing the problem?


  2. #2
    tweeker's Avatar
    Join Date
    Jul 2007
    Location
    Denver NC
    Posts
    706
    +1
    45
    check the two large 30 amp fuses that attach to the side of the mpem, prolly a poor connection there

  3. #3
    boost junkie skidoochris's Avatar
    Join Date
    Mar 2012
    Location
    Davison, Mi
    Posts
    4,494
    +1
    476
    motor grounds may be loose or corroded

  4. #4
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    6,529
    +1
    1,279
    get a good voltmeter on it and see if it's really low

    or

    wait for it to crap out 100%


    please note:
    crapping out can often come at a most inconvenient moment

    RFI model seadoos are prone to this particular issue.

  5. #5

    Join Date
    Sep 2012
    Location
    Westchester,NY
    Posts
    172
    +1
    6
    I have an 05RXT that did this. First verify your battery is good, if so, check voltage while the ski is running. Should get about 14vdc. If you dont get 14vdc then start tracing your wires from battery to ground, regulator, connectors and stator. I had a bad connector up front at the regulator. The wires showed high resistence on my ohm meter whenringing them out. Cleaned the contacts and problem solved.

  6. #6
    rangermtb5's Avatar
    Join Date
    Apr 2008
    Location
    North Jersey
    Posts
    4,473
    +1
    58
    make the the regulator connector is seating tight. left mine slightly loose and i got the warning.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rxp 12v low/new battery
    By rxprsn in forum 4-Tec Performance
    Replies: 18
    Last Post: 08-29-2009, 04:32 PM
  2. 155 Speedster 12V LOW
    By strmchzr in forum Sea Doo Sport Boats
    Replies: 13
    Last Post: 06-09-2008, 08:14 AM
  3. 12V LOW alarm
    By H2HO in forum 4-Tec Performance
    Replies: 31
    Last Post: 12-26-2007, 12:13 PM
  4. Display reads 12V LOW
    By 01xdime in forum 4-Tec Performance
    Replies: 7
    Last Post: 02-18-2007, 09:56 PM
  5. 12V LOW!!!
    By meeper in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 05-30-2006, 09:21 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •