Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 22
  1. #1
    Live Fast wave15stx's Avatar
    Join Date
    May 2007
    Location
    new jersey
    Posts
    2,214
    +1
    32

    oil in the engine compartment rxtx 260

    today was the second time im noticeing oil in the engine compartment seems to be a decent amount im also getting some water so its mixing and splashes around hull getting some in the catch can but not alot maybe a teaspoon.i dont think its coming from the catch can filter cause theres no oil in the upper part of the hull where the filter is seems to be mostly in the front lower part of the motor.the ski is running perfect and the speed/rpms are up, i also did a compression test 125 on all cylinders.im trying to keep the afr low to mid 12s but around 8000 rpm i its dropping to 11.3, i need to fine tune that part and i got injectors on order.where can the oil be coming from heres couple pics
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	photo ski bilge 2.jpg 
Views:	99 
Size:	194.0 KB 
ID:	317458   Click image for larger version. 

Name:	photo ski bilge.jpg 
Views:	98 
Size:	211.0 KB 
ID:	317459   Click image for larger version. 

Name:	photoski bilge 3.jpg 
Views:	94 
Size:	198.1 KB 
ID:	317460  


  2. #2
    Live Fast wave15stx's Avatar
    Join Date
    May 2007
    Location
    new jersey
    Posts
    2,214
    +1
    32
    second pic is after i cleaned the hull out didnt mean to post that one.i wanna test it again this week see if i can pinpoint whats going on

  3. #3
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,260
    +1
    117
    check the pto shaft seal. the hose clamp on mine keeps getting loose causing it to leak oil.

  4. #4
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,849
    +1
    742
    Most probably your PTO seal is leaking and is very common. Been there done that.

  5. #5
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,849
    +1
    742
    Replace #50-53 and check your engine alignment while you have the drive shaft removed.

    http://partsfinder.onlinemicrofiche.....-W/-PTO-COVER

  6. #6
    Live Fast wave15stx's Avatar
    Join Date
    May 2007
    Location
    new jersey
    Posts
    2,214
    +1
    32
    I'll look into that thanks guys

  7. #7

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    3,444
    +1
    653
    Quote Originally Posted by jpt7779 View Post
    Replace #50-53 and check your engine alignment while you have the drive shaft removed.

    http://partsfinder.onlinemicrofiche.....-W/-PTO-COVER
    What is the recommendation of when to change out the PTO? I'm at 110 hrs...just removed my drive shaft etc.

    Went to go check the alignment with my trusty SBT alignment kit...but the pump mount is very different from my 2012 PX260. Have no idea what I'm doing and the their isn't a service manual on the CanDooPro site. .

  8. #8
    stuckmoto's Avatar
    Join Date
    Jun 2010
    Location
    Newark, De
    Posts
    1,485
    +1
    59
    Quote Originally Posted by jpt7779 View Post
    Most probably your PTO seal is leaking and is very common. Been there done that.
    +1 had the same issue TWICE!

  9. #9
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,849
    +1
    742
    The other oil leak source is the "oil radiator" part #34 heat exchanger. Not as common as the PTO seal leaking, but possible. Also realize the PTO seal doesn't tend to leak at rest, but will pour out the oil while running in just a few minutes.

    http://partsfinder.onlinemicrofiche....W/-ACCESSORIES

    Have you got any new vibrations, excessive wear ring wear?

  10. #10
    www.eastcoastpwc.net Scott's Avatar
    Join Date
    Jul 2007
    Location
    NJ
    Posts
    7,991
    +1
    455
    Wtf. This is a brand new ski.

  11. +1 by:


Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 07-11-2016, 10:11 AM
  2. 2012 rxtx 260 oil in the antifreeze
    By wave15stx in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-29-2014, 01:22 PM
  3. Water in the engine compartment???
    By gilamonster in forum Polaris How To & FAQs
    Replies: 22
    Last Post: 07-11-2013, 11:05 PM
  4. Lots of oil in the engine.
    By cwag911 in forum Polaris Open Discussion
    Replies: 28
    Last Post: 11-11-2009, 10:51 AM
  5. Dropped Socket in the engine compartment
    By cbsmith in forum Sea Doo Open Discussion
    Replies: 20
    Last Post: 05-27-2009, 10:09 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •